synaptikscfg crashed with KeyError in __setitem__(): u'circular_touchpad'

Bug #1102032 reported by SD
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
synaptiks (Ubuntu)
Medium
Philip Muškovac
Raring
Undecided
Philip Muškovac

Bug Description

[Impact]
Due to removed keys in the configuration class the de-serialization of old touchpad settings fail which breaks the touchpad configuration.

[Test Case]
1) You need a ~/.config/synaptiks/touchpad-config.json like the one attached to the report (containing the configuration keys that cause the issue)
2) run 'synaptikscfg load' which should show backtrace below
3) install kde-config-touchpad from raring-proposed
4) run 'synaptikscfg load' again which shouldn't crash anymore

[Regression Potential]
As the keys were only added back to the backend as dummies and have no effect in application anymore there should be none.

42: PS/2 00.0: 10500 PS/2 Mouse
  [Created at input.183]
  UDI: /org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input
  Unique ID: AH6Q.ZHI3OT7LsxA
  Hardware Class: mouse
  Model: "SynPS/2 Synaptics TouchPad"
  Vendor: 0x0002
  Device: 0x0007 "SynPS/2 Synaptics TouchPad"
  Compatible to: int 0x0210 0x0002
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event9, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/input/by-path/platform-i8042-serio-4-mouse
  Device Number: char 13:63 (char 13:32)
  Driver Info #0:
    Buttons: 2
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown

ProblemType: CrashDistroRelease: Ubuntu 13.04
Package: kde-config-touchpad 0.8.1-1ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic x86_64
ApportVersion: 2.8-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Sun Jan 20 17:58:40 2013
ExecutablePath: /usr/bin/synaptikscfg
InstallationDate: Installed on 2012-12-15 (36 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/synaptikscfg init
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/synaptikscfg', 'init']SourcePackage: synaptiks
Title: synaptikscfg crashed with KeyError in __setitem__(): u'circular_touchpad'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
SD (sadovsky-dmitry) wrote :
tags: removed: need-duplicate-check
Changed in synaptiks (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptiks (Ubuntu):
status: New → Confirmed
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1102032

tags: added: iso-testing
Philip Muškovac (yofel)
Changed in synaptiks (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
Changed in synaptiks (Ubuntu Raring):
assignee: nobody → Philip Muškovac (yofel)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptiks - 0.8.1-1ubuntu4

---------------
synaptiks (0.8.1-1ubuntu4) saucy; urgency=low

  * Fix 0001-Remove-several-features-that-will-no-longer-be-expos.patch to
    not remove keys from the touchpad configuration. (LP: #1102032)
 -- Philip Muskovac <email address hidden> Sun, 28 Apr 2013 16:29:25 +0200

Changed in synaptiks (Ubuntu):
status: Confirmed → Fix Released
SD (sadovsky-dmitry)
Changed in synaptiks (Ubuntu Raring):
status: New → Fix Released
Philip Muškovac (yofel)
Changed in synaptiks (Ubuntu Raring):
status: Fix Released → New
Revision history for this message
Philip Muškovac (yofel) wrote :
description: updated
Revision history for this message
Scott Kitterman (kitterman) wrote : Please test proposed package

Hello SD, or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in synaptiks (Ubuntu Raring):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Scott Kitterman (kitterman) wrote :

Reproduced on the system I've seen the traceback on before, upgraded and no traceback. v-done.

You can't reproduce this on any system. I have another one where I couldn't reproduce the bug even with the config file from the bug. Thanks for the fix.

tags: added: verification-done
removed: amd64 apport-crash verification-needed
Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptiks - 0.8.1-1ubuntu3.1

---------------
synaptiks (0.8.1-1ubuntu3.1) raring; urgency=low

  * Fix 0001-Remove-several-features-that-will-no-longer-be-expos.patch to
    not remove keys from the touchpad configuration. (LP: #1102032)
 -- Philip Muskovac <email address hidden> Sun, 28 Apr 2013 16:29:25 +0200

Changed in synaptiks (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers