E: Значение «oneiric» недопустимо для APT::Default-Release, так как выпуск недоступен в источниках E: _cache->open() failed, please report.

Bug #978821 reported by Pavel-II
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

E: The value 'oneiric' is invalid for APT::Default-Release as such a release is not available in the sources
E: _cache->open() failed, please report.

But:

$ sudo grep -r oneiric /etc/apt | wc -l
0
$

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: synaptic 0.75.9
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0.1-0ubuntu1
Architecture: amd64
Date: Wed Apr 11 14:58:52 2012
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
SourcePackage: synaptic
UpgradeStatus: Upgraded to precise on 2012-03-30 (11 days ago)

Revision history for this message
Pavel-II (dzy4) wrote :
Revision history for this message
hexafraction (rarkenin) wrote :

If any non-russian speakers need a translation, the first two lines are E:Index "oeniric" invalid for APT::DefaultRelease, as the release is unavailable in sources
(Or something along those lines)

Revision history for this message
hexafraction (rarkenin) wrote :

How was this reproduced?

Changed in synaptic (Ubuntu):
assignee: nobody → Robert Arkenin (rarkenin)
assignee: Robert Arkenin (rarkenin) → nobody
Revision history for this message
Pavel-II (dzy4) wrote :

This happens when I run synaptic as root ( sudo synaptic ).
Screenshot in the attached file.

Revision history for this message
Olzirg (olzirg) wrote :

I have had the same problem.
You have the Y-PPA-Manager?
Try Settings - Reset to default in this package.

Revision history for this message
Pavel-II (dzy4) wrote :

I do not use Y-PPA-Manager.

"Try Settings - Reset to default in this package."
in which the application to do this?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Robert Roth (evfool)
description: updated
Revision history for this message
Romulus (launchpad-keithtyler) wrote :

Places to check:
/etc/apt/apt.conf.d/10periodic
Look for "APT::Default-Release" line.

Check your /etc/apt/sources.list file. Does that term appear there?

After an update, my sources.list was mass-changed from "oneiric" to "precise". But I haven't upgraded the system to precise yet. (At least, the system doesn't think so.)

In sources.list, I copied the top two lines that read:

deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted

and edited them to say:

deb http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted

Then, update-manager offered a "Partial upgrade". Not quite working, but appears to be progress.

I suppose one could also try changing the APT::Default-Release from "oneiric" to "precise", too.

Revision history for this message
Romulus (launchpad-keithtyler) wrote :

Seemed to work OK after mass-replacing all "precise" back to "oneiric" in sources.list.

Revision history for this message
Romulus (launchpad-keithtyler) wrote :

Hmm. Seems to be a bug in the 12.04 dist-upgrade routine. It edits sources.list, but not apt.conf.d, so there is a mismatch on release name between sources.list (which all says "precise") and APT::Default-Release (which still says "oneiric").

main.log:
2012-06-04 12:00:16,910 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ oneiric-backports restricted main multiverse universe'
2012-06-04 12:00:16,911 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ precise-backports restricted main multiverse universe' updated to new dist
2012-06-04 12:00:16,938 DEBUG running doUpdate() (showErrors=True)
2012-06-04 12:00:24,360 DEBUG openCache()
2012-06-04 12:00:24,361 DEBUG failed to SystemUnLock() (E:Not locked)
2012-06-04 12:00:28,767 ERROR not handled expection:
Traceback (most recent call last):

  File "/tmp/update-manager-7O1E7_/precise", line 7, in <module>
    sys.exit(main())

  File "/tmp/update-manager-7O1E7_/DistUpgradeMain.py", line 225, in main
    if app.run():

  File "/tmp/update-manager-7O1E7_/DistUpgradeController.py", line 1721, in run
    return self.fullUpgrade()

  File "/tmp/update-manager-7O1E7_/DistUpgradeController.py", line 1639, in fullUpgrade
    self.openCache()

  File "/tmp/update-manager-7O1E7_/DistUpgradeController.py", line 192, in openCache
    lock)

  File "/tmp/update-manager-7O1E7_/DistUpgradeCache.py", line 92, in __init__
    apt.Cache.__init__(self, progress)

  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 93, in __init__
    self.open(progress)

  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 136, in open
    self._cache = apt_pkg.Cache(progress)

SystemError: E:The value 'oneiric' is invalid for APT::Default-Release as such a release is not available in the sources

Revision history for this message
Pavel-II (dzy4) wrote :

$ cat /etc/apt/apt.conf.d/10periodic
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Download-Upgradeable-Packages "1";
APT::Periodic::AutocleanInterval "0";
APT::Periodic::Unattended-Upgrade "1";
$

Revision history for this message
Misaki (myjunkmail311006) wrote :

From http://ubuntuforums.org/showthread.php?p=11403493

The APT::Default-Release identifier is within Synaptic config file at each home directory (for you and root). I have recreated this error by manually editing those files.

Going to /root/.synaptic/synaptic.conf and changing the default distro to precise fixed it for me.

Revision history for this message
Pavel-II (dzy4) wrote :

<<< Going to /root/.synaptic/synaptic.conf and changing the default distro to precise fixed it for me.

Its work!

Case closed.

Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
rtimai (rtimai) wrote :

This issue recurred in Synaptic version .0.75.12 running in Ubuntu 12.10, with Default-Release identifier 'precise.' When 'precise' is replaced with 'quantal' in /root/.synaptic/synaptic.conf, then starting /user/bin/synaptic-pkexec (and locking icon to Launcher) Synaptic now runs normally, prompting for sudo password and opening normally. In this case there were no mis-matches in sources.list or /etc/apt/apt.conf.d/10periodic.

Good information in this thread! Thank you so much!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers