Missing information in "unresolvable dependencies" dialog

Bug #9094 reported by Ronald St. on 2004-10-14
6
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Medium
Michael Vogt

Bug Description

I wanted to update a package from a third party repository, but it turns out
that the deps have been changed and unfortunatly can't be met with ubuntu
packages. That's not the point, the point is that I get this when trying to
update via synaptic:

Depends: libartsc0 but 1.2.3-1 is to be installed
Depends: libggi2 but 1:2.0.4-3 is to be installed
Depends: libungif4g but 4.1.0b1-6 is to be installed

vs. this when I try updating via apt-get:

Depends: libartsc0 (>= 1.3.0) but 1.2.3-1 is to be installed
Depends: libggi2 (>= 1:2.0.5) but 1:2.0.4-3 is to be installed
Depends: libungif4g (>= 4.1.3) but 4.1.0b1-6 is to be installed

You see that the "needed" version numbers are not displayed in synaptic.

Michael Vogt (mvo) wrote :

Thanks for this bugreport. This information is indeed missing. I fixed it in my
local
repository and it will be part of the next synaptic release. It's unlikely that
it will
make it into warty-final, as we are in a deep feature freeze. But I can make
unofffical
packages of the current development version available if you are curious.

thanks,
 Michael

Michael Vogt (mvo) wrote :

should be fixed with the upload of 0.55+cvs2004113. please confirm

Ronald St. (photicsneezereflex) wrote :

Bug seems to be fixed with 0.55+cvs2004113, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.