Synaptic wants to reinstall all recomended packages on upgrade

Bug #82876 reported by kivan on 2007-02-02
2
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Michael Vogt
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: synaptic

I purged some packages recomended by kubuntu-desktop. I am now trying to upgrade it from version 1.25 to 1.26, and synaptics wants to reinstall them again. This also happens if I try apt from the command line, so it probably isn't a bug in synaptic itself. The program should probably install by default the recommends of the newer version that aren't present in the old one, but it should avoid installing again the packages that were manually removed.

Michael Vogt (mvo) wrote :

This seems to be a apt problem.

Changed in synaptic:
status: Unconfirmed → Rejected
Michael Vogt (mvo) on 2007-02-12
Changed in apt:
status: Unconfirmed → Confirmed
Tollef Fog Heen (tfheen) on 2007-03-30
Changed in apt:
assignee: nobody → mvo
Michael Vogt (mvo) wrote :

I tried to reproduce this problem here without success so far. Here is what I setup:

Package: recommends-test-package
Version: 1.1
Recommends: 3dchess, 2vcard
[..]

Package: recommends-test-package
Version: 1.0
Recommends: 3dchess
[..]

# apt-get install --allow-unauthenticated --install-recommends recommends-test-package=1.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  3dchess recommends-test-package
The following NEW packages will be installed:
  3dchess recommends-test-package

# dpkg -r 3dchess(Reading database ... 290520 files and directories currently installed.)
Removing 3dchess ...

# apt-get install --allow-unauthenticated --install-recommends recommends-test-package

# apt-get install --allow-unauthenticated --install-recommends recommends-test-package
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  2vcard
Recommended packages:
  3dchess
The following NEW packages will be installed:
  2vcard
The following packages will be upgraded:
  recommends-test-package
1 upgraded, 1 newly installed, 0 to remove and 347 not upgraded.

The '3dchess' package that I removed earlier is not marked for reinstall (as designed). The same works for "apt-get dist-upgrade --install-recommends".

The same is true if I move the recommends-test-packages into the meta-packages section.

Michael Vogt (mvo) wrote :

It turns out that the problem is that the section of ubuntu-desktop (or kubuntu-desktop for that matter) is "base" in the /var/lib/dpkg/status file. When apt calculates the new recommends this causes confusion as apt will currently only consider recommends for section "metapackages" as ImportantDeps().

Changed in apt:
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

The fix is to change the Section in ubuntu-meta to "metapackages". This should ensure that the correct section goes into /var/lib/dpkg/status

Michael Vogt (mvo) wrote :

This is fixed with my recent uploads of {ku,u,xu,edu}buntu-meta that changes the Section to metapackages.

Changed in apt:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers