"Reload" button on "repos have changed, click reload" dialog

Bug #78987 reported by Shish on 2007-01-12
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: synaptic

After changing repository options I get told "repositories changed, you have to click on the reload button", and it presents me with a "close" button and nothing else. After a few seconds I realise that it's telling me to click a button in an entirely different window. I try clicking the reload button in the other window, but nothing happens. Then I realise I have to close the information dialog first, thus getting rid of the instructions that I'm supposed to follow, and only *then* can I follow them...

Having a "reload" button on the window that says "click the reload button" would make things much more intuitive.

Related branches

Sebastian Heinlein (glatzor) wrote :

Thanks.

Changed in synaptic:
assignee: nobody → glatzor
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :

Thanks for this bugreport.

This is indeed a usability problem. We probably want a button that says "reload now" in additon to the close button.

Cheers,
 Michael

Changed in synaptic:
importance: Undecided → Low
Conrad Knauer (atheoi) wrote :

This has been bothering me for a while now too; screenshot attached.

Michael Vogt (mvo) on 2007-10-17
Changed in synaptic:
milestone: none → later
Endolith (endolith) wrote :

I was going to suggest this, too. Mock-up of what I think it should look like.

Dylan McCall (dylanmccall) wrote :

I believe the 'out of date repositories' dialog has a Reload button right on it, so it would be good to keep the language and layout consistent between the two. (Perhaps even use the same dialog).

This is an old bug and probably an easy one to propose fixes to. Is there somewhere we can put this to promote it for people looking for quick and effective hacking jobs? (Something like GNOME Love?)

Endolith (endolith) wrote :

I didn't realize this, but the Software Sources app already does this. It looks exactly the same as Synaptic's Repositories tool, so I don't see why Synaptic doesn't have the exact same dialog for reloading.

Micah Gersten (micahg) wrote :

There is sufficient information for development, so I am marking this as triaged.

Changed in synaptic (Ubuntu):
status: Confirmed → Triaged
Robert Roth (evfool) wrote :

Changing the affected package from synaptic to software-properties as the dialog is implemented there.

affects: synaptic (Ubuntu) → software-properties (Ubuntu)
Robert Roth (evfool) on 2012-02-15
affects: software-properties (Ubuntu) → synaptic (Ubuntu)
Robert Roth (evfool) on 2012-02-15
Changed in synaptic (Ubuntu):
assignee: Sebastian Heinlein (glatzor) → Robert Roth (evfool)
status: Triaged → In Progress
Robert Roth (evfool) on 2012-07-13
Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
dino99 (9d9) wrote :

Well hopes to see this "fix commited" changed into "fix released" asap

because of : bug #1026130 & bug #1026138 (both synaptic & software-properties are broken right now)

dino99 (9d9) wrote :

Since we got aptdaemon 0.45+bzr848 upgrade, this problem is now hidden as the report message does not popup now because the Settings Repositories works , calling Software-properties-gtk, but this gui is very very slow to open, much more than before when synaptic was not calling/using software-properties-gtk.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp1

---------------
synaptic (0.80~exp1) experimental; urgency=low

  [ Robert Roth ]
  * * Disables typeahead in summary dialog, as it doesn't do anything,
    so it's unnecesary (LP: #24319)
  * Move up and Move down buttons in columns preferences changed to
    respect buttons_have_icons preference (LP: #66574)
  * Set the title of the package properties dialog opened for the first
    time (it has not been set before, so it was synaptic the first time
    the dialog has been opened) (LP: #932495)
  * Added a reload button to the repositories changed dialog (LP: #78987)
  * Updated the wording of the expander on the download progress dialog to
    Show individual files" instead of "Show for individual files"
    (LP: #301428)
  * Fixed inconsistencies between column namings in column headers and
    column visibility preferences (LP: #335723)
  * Linkified maintainer label in the package properties dialog
    when running as non-root (LP: #321380)
  * Added package name in the warning scaring you about breaking your
    system (LP: #63974)
  * Added name of the application (Synaptic Package Manager) in the
    titleless dialog shown when starting without administrative
    privilegess (LP: #510261)
  * Improved filter editing checkbox tooltips (LP: #790420)
  * Made all the property values from the package properties dialog
    selectable (LP: #173464)
  * Changed Package Properties accelerator from Ctrl+O to widely used
    (nautilus, eog, evince etc) Alt+Enter (LP: #933554)
  * Use the synaptic icon from the user's icon theme, or fall back to
    the old one if the current theme does not provide a synaptic icon
    (LP: #153755)
  * Focus the Apply button by default. (LP: #488718)
  * Removed log message from automatically installed item click
    (LP: #883984)
  * Fixed delete filter button not working caused by a typo in the
    name of the button when getting it from the GtkBuilder object
    (LP: #779756)
  * Added suggests tasksel as with tasksel installed synaptic
    provides additional functionality (LP: #605186)
  * Fixes incorrect radiobutton handling in the proxy preferences
    (LP: #706262)
  * Fixed incorrect status message when canceling 'Mark all available
    upgrades' feedback dialog (LP: #975578)

  [ Michael Vogt ]
  * ensure external helpers are runs as the user uid
  * build for gtk3 and update build-depends
  * move software-propoerties-gtk into suggests
  * strip strings properly in a markings file, thanks to
    Vassilis Palassopoulos (palasso)
  * show source package name in the details (closes: #692528)
  * merged lp:~fitoschido/synaptic/es-redundancy:
    - Remove empty es_ES .po files. Spanish translations are already
      provided in es files. Thanks to Adolfo Jayme Barrientos (fitoschido)
  * common/rpackagelister.cc:
    - add support for complete removal (purge) in the markings file

 -- Michael Vogt <email address hidden> Thu, 13 Dec 2012 10:08:37 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers