Synaptic crashes when started

Bug #787173 reported by Børge Johannessen on 2011-05-23
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux Mint
synaptic (Debian)
synaptic (Ubuntu)

Bug Description

After updating quite a few files after clean install, my synaptic crashes when I start it up.
I got the password check, after that I only see the synaptic for half a second before I'm back to desktop.
This is now the issue on 2/2 of my lmde-running computers, synaptic worked just fine before updating on both computers.
Terminal and update manager works.

description: updated
Børge Johannessen (lmdebruker) wrote :

(synaptic:12655): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

affects: → linuxmint
Børge Johannessen (lmdebruker) wrote :

If someone interested, used aptitude to fix all broken packages but it doesn't help me with synaptic.

Also, the pango-warnings shows different numbers every time (like synaptic:12655)

tags: added: 201012 debian linux mint
André Savik (asavik) wrote :

This happens to me too, on Oneiric. I notice the bug seems to affect several Norwegian users, so I tried sudo LANG=en_EN.utf8 synaptic and the problem went away. So the developers might look into that...

Børge Johannessen (lmdebruker) wrote :

@Andre Savik - Thankyou... I'm sure the developers finally will fix this, and I can understand it has taken time if only the norwegian languange is affected by this, but it's have been like a year now without synaptic so your solution is much appreaciated.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Changed in synaptic (Debian):
status: Unknown → New
Kjetil Rydland (kjetilrydl) wrote :

sudo LANG=en_EN.utf8 synaptic works for me as well.

crtm (carlosrtm) wrote :

If running in a terminal, the warning is:

sudo synaptic :
(synaptic:4808): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap»,
terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

Marius B. Kotsbak (mariusko) wrote :

Still happens in latest version of Precise. See bug #952392.

tags: added: precise
Marius B. Kotsbak (mariusko) wrote :

I guess this must be a duplicate of a more "popuplar" bug #839219, as the same workaround applies there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.