synaptic network proxy preferences don't clear properly on Cancel

Bug #706262 reported by Eliah Kagan on 2011-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
synaptic
New
Undecided
Unassigned
synaptic (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: synaptic

In synaptic 0.75~pre4 on Natty i386, in the Network tab of the Preferences, the proxy preferences don't clear properly when the Cancel button is clicked. While I do not believe any proxy behavior is actually altered so long as Cancel is clicked, selecting "Manual proxy configuration", clicking Cancel, and then returning to the Preferences during the same Synaptic session shows "Manual proxy configuration" still selected. However, the controls under "Manual proxy configuration" used to specify the manual configuration are faded out, as though "Direct connection to the internet" were selected. This is shown in the attached screenshot.

After selecting "Manual proxy configuration" and clicking Cancel, if I quit Synaptic and launch it again, this effect disappears.

I am also able to produce this bug with synaptic 0.63.1ubuntu4 on a Maverick amd64 system.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: synaptic 0.75~pre4
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
Date: Sat Jan 22 07:24:34 2011
ExecutablePath: /usr/sbin/synaptic
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110120)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: synaptic

Related branches

Robert Roth (evfool) on 2012-02-19
Changed in synaptic (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Robert Roth (evfool) on 2012-02-19
Changed in synaptic (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Confirmed → In Progress
Robert Roth (evfool) on 2012-07-13
Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp1

---------------
synaptic (0.80~exp1) experimental; urgency=low

  [ Robert Roth ]
  * * Disables typeahead in summary dialog, as it doesn't do anything,
    so it's unnecesary (LP: #24319)
  * Move up and Move down buttons in columns preferences changed to
    respect buttons_have_icons preference (LP: #66574)
  * Set the title of the package properties dialog opened for the first
    time (it has not been set before, so it was synaptic the first time
    the dialog has been opened) (LP: #932495)
  * Added a reload button to the repositories changed dialog (LP: #78987)
  * Updated the wording of the expander on the download progress dialog to
    Show individual files" instead of "Show for individual files"
    (LP: #301428)
  * Fixed inconsistencies between column namings in column headers and
    column visibility preferences (LP: #335723)
  * Linkified maintainer label in the package properties dialog
    when running as non-root (LP: #321380)
  * Added package name in the warning scaring you about breaking your
    system (LP: #63974)
  * Added name of the application (Synaptic Package Manager) in the
    titleless dialog shown when starting without administrative
    privilegess (LP: #510261)
  * Improved filter editing checkbox tooltips (LP: #790420)
  * Made all the property values from the package properties dialog
    selectable (LP: #173464)
  * Changed Package Properties accelerator from Ctrl+O to widely used
    (nautilus, eog, evince etc) Alt+Enter (LP: #933554)
  * Use the synaptic icon from the user's icon theme, or fall back to
    the old one if the current theme does not provide a synaptic icon
    (LP: #153755)
  * Focus the Apply button by default. (LP: #488718)
  * Removed log message from automatically installed item click
    (LP: #883984)
  * Fixed delete filter button not working caused by a typo in the
    name of the button when getting it from the GtkBuilder object
    (LP: #779756)
  * Added suggests tasksel as with tasksel installed synaptic
    provides additional functionality (LP: #605186)
  * Fixes incorrect radiobutton handling in the proxy preferences
    (LP: #706262)
  * Fixed incorrect status message when canceling 'Mark all available
    upgrades' feedback dialog (LP: #975578)

  [ Michael Vogt ]
  * ensure external helpers are runs as the user uid
  * build for gtk3 and update build-depends
  * move software-propoerties-gtk into suggests
  * strip strings properly in a markings file, thanks to
    Vassilis Palassopoulos (palasso)
  * show source package name in the details (closes: #692528)
  * merged lp:~fitoschido/synaptic/es-redundancy:
    - Remove empty es_ES .po files. Spanish translations are already
      provided in es files. Thanks to Adolfo Jayme Barrientos (fitoschido)
  * common/rpackagelister.cc:
    - add support for complete removal (purge) in the markings file

 -- Michael Vogt <email address hidden> Thu, 13 Dec 2012 10:08:37 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers