Cannot select previous search terms from the dropdown to repeat a search

Bug #688769 reported by Ky6uk on 2010-12-10
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Unassigned

Bug Description

Steps to reproduce:
1. Open synaptic
2. Press Ctrl+f to open the search dialog.
3. Write something and search for it.
4. Press Ctrl+f to open the search dialog again.
5. Write something else in the text field.
6. Click the arrow to open the drop down list and try to select the previous search term by clicking on it.

Expected result:
The clicked item is selected and inserted in the text field.

Actual result:
Nothing happens.

Original report:
Binary package hint: synaptic

I can't change keyword from search history. Mouse click don't work. More info attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: synaptic 0.75~pre2
ProcVersionSignature: Ubuntu 2.6.37-8.21-generic 2.6.37-rc4
Uname: Linux 2.6.37-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Dec 11 02:32:38 2010
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100630.1)
ProcEnviron:
 LANGUAGE=ru_RU
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: synaptic

Related branches

Ky6uk (ky6uk) wrote :
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue. I experience the same behaviour on Natty. When using find (ctrl+f) it is impossible to select older strings from the dropdown.
I ran synaptic from the terminal and noticed when I click on an earlier entry in the dropdown, the following error message is printed:
(synaptic:4608): Gtk-CRITICAL **: IA__gtk_entry_set_text: assertion `text != NULL' failed

Changed in synaptic (Ubuntu):
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

I notice this is also reproducible on Ubuntu 11.10 (see duplicate) and Ubuntu Precise (I just tried).

description: updated
summary: - Package search issue
+ Cannot select previous search terms from the dropdown to repeat a search
tags: added: oneiric precise
Bilal Shahid (s9iper1) wrote :

 marking it as triaged and importance low as per the request in xchat IRC channel.
thanks hjd

Changed in synaptic (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Hans Joachim Desserud (hjd) wrote :

Fwiw, selecting older search terms from the drops down works without any problems in version 0.63.1ubuntu7 on Ubuntu 10.04. Looks like it regressed at some point after this.

tags: added: regression-release

Still reproducible in 12.04 (precise)

Robert Roth (evfool) wrote :

Still reproducible on the latest version, but is not happening with the GTK3 port, so I have attached this bug to the branch, and as soon as the gtk3 port gets merged into trunk, we can mark this as fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers