Synaptic doesn't honor pinning rules in /etc/apt/preferences.d/

Bug #628818 reported by Matt Lavin
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

I have a Lucid system installed, but I wanted to test the kernels from Maverick. To accomplish this, I added the Maverick repositories to my /etc/apt/sources.list file, but I setup apt pinning to only get kernel updates from Maverick. To setup the apt pinning I created a file:

/etc/apt/preferences.d/maverick-pin with the following contents:

   Package: linux-image-generic-pae
   Pin: release o=Ubuntu,a=maverick
   Pin-Priority: 500

   Package: *
   Pin: release o=Ubuntu,a=maverick
   Pin-Priority: 400

When I ran "apt-get dist-upgrade" it correctly showed that a new kernel version was available and I installed it. After the upgrade I ran "apt-get upgrade -uV" again to make sure I was completely up to date. Here was the output:

   $ sudo apt-get upgrade -uV
   Reading package lists... Done
   Building dependency tree
   Reading state information... Done
   0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I launch Synaptic to search for a new package to install, and it tells me that I have many updates available, but it seems to be ignoring the pinning rules I've setup.

One package it tells me I should upgrade is "acpid". When I run "apt-cache policy acpid" it shows me that there is a newer version in Maverick, but because of the pinning rules that newer version should not be considered for upgrade:

acpid:
  Installed: 1.0.10-5ubuntu2.1
  Candidate: 1.0.10-5ubuntu2.1
  Version table:
     1.0.10-5ubuntu4 0
        400 http://us.archive.ubuntu.com/ubuntu/ maverick/main Packages
 *** 1.0.10-5ubuntu2.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        100 /var/lib/dpkg/status
     1.0.10-5ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages

Michael Vogt (mvo)
Changed in synaptic:
status: New → In Progress
importance: Undecided → Medium
Revision history for this message
David Clayton (dcstar) wrote :
Revision history for this message
Daniel Hartwig (wigs) wrote :

synaptic (0.75) unstable; urgency=low

  * common/rpackagecache.cc:
    - read pindir as well as the pinfile (LP: #628818)

affects: synaptic → synaptic (Ubuntu)
Changed in synaptic (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers