[Edgy] Segmentation Fault when doing various operations

Bug #62298 reported by Julien Lavergne on 2006-09-25
4
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: synaptic

When I finish some operations (update, install or remove), the CPU work at 100% for several seconds and synaptic crash. Operation are committed when I reopen synaptic.

Related branches

Julien Lavergne (gilir) wrote :

I have a apport report, but it's seem to be empty. I'll try to do a backtrace.

Simon Law (sfllaw) wrote :

Thank you. Please follow the instructions at https://wiki.ubuntu.com/Backtrace.

Changed in synaptic:
assignee: nobody → sfllaw
status: Unconfirmed → Needs Info
Julien Lavergne (gilir) wrote :

I try to compile with debug synaptic, but it doesn't work. When I launch gdb synaptic and run, I see : (no debugging symbols found). Can I do a backtrace without them ?
But, I found a way to post the apport report.

Simon Law (sfllaw) wrote :

The apport report is good enough. Thanks!

Changed in synaptic:
assignee: sfllaw → nobody
importance: Untriaged → Medium
status: Needs Info → Confirmed
Michael Vogt (mvo) wrote :

What operation did you perform when this apport crash happend?

Julien Lavergne (gilir) wrote :

I removed some linux-* packages if my memory is good.

Julien Lavergne (gilir) wrote :

I reproduce the bug, during an update this time

Michael Vogt (mvo) wrote :

Can you please test this patch and let me know if it fixes the issue for you? You may have to rebuild apt first to make it build because of bug #62461).

Thanks,
 Michael

Julien Lavergne (gilir) wrote :

The patch seem to work. After some install/remove and update, no more bug. Thanks :)
I see that you have release the patch, so I switch the statut of the bug.

Changed in synaptic:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Michael Vogt (mvo) wrote :

Thanks a lot for verifiying the fix! Unfortunately (because of #62298) synaptic is not yet rebuild. I put it into fix-commited until the build is completed.

Changed in synaptic:
assignee: nobody → mvo
status: Fix Released → Fix Committed
Michael Vogt (mvo) on 2006-09-27
Changed in synaptic:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers