Synaptic cannot force version in Lucid

Bug #568925 reported by Eemil Lagerspetz on 2010-04-23
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
High
Jean-Baptiste Lallement
Nominated for Karmic by justin
Nominated for Maverick by justin
Lucid
High
Jean-Baptiste Lallement

Bug Description

Binary package hint: synaptic

I am trying to downgrade previously installed packages, whose repository I had enabled in Karmic. in Lucid, synaptic allows me to choose "Force version" for a package, but after I choose the version and press ok, synaptic shows no pending changes.

TEST CASE:
1. use synaptic from lucid
2. make sure you have lucid-proposed enabled
3. install acpid from lucid-proposed (or any other package from -proposed except synaptic)
4. open synaptic and search for acpid
5. press ctrl-e (or go to the package/force version menu)
6. force the version to "lucid"
7. verify that it does not do that (i.e. apply button in the toolbar stays gray, icon does not change)

8. install synaptic from lucid-proposed
9. repeat 4,5,6
10. verify that the apply button becomes visible and that the icon close to the package changes

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: synaptic 0.63.1ubuntu6
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Apr 23 14:13:15 2010
SourcePackage: synaptic

Related branches

Daniel Baumann (dnjl) wrote :

Affects me to. I deselected a development ppa and now I am not able to downgrade any package with current synaptic version.
I installed the older version 0.63.1ubuntu3 of synaptic with dpkg which works for me.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Changed in synaptic (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
importance: Undecided → High
status: Confirmed → In Progress
Jean-Baptiste Lallement (jibel) wrote :

commit to bzr ~jibel/synaptic/bug.566779/ r96

Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Daniel Baumann (dnjl) wrote :

I confirm this fix.

Who is interested in the package until it's released will find it at:
https://launchpad.net/~dnjl/+archive/experimental/+sourcepub/1086926/+listing-archive-extra

Fix works. Thanks for the debs.

Jean-Baptiste Lallement (jibel) wrote :

SRU: minimal patch for lucid committed to bzr

Trivial fix: remove a test introduced during beta2 to fix bug 513460 when a user applies the same action to a list of packages.
This is not needed when forcing a version since "Force Version" only applies to the first selected package in the list.

Note to devs:
The real fix would be to disable "Force Version" in menu when multiple packages are selected.

I have the problem also when just one package is selected. Actually, I didn't even try with multiple packages. Is test you talk about in "trivial fix" done also for just one selected package?

Jean-Baptiste Lallement (jibel) wrote :

Yes, it fixes the case when a single package is selected.
For your reference, bug 513460, allowed a user to select multiple packages and apply the same action to this list, even a not allowed action for a some packages. I've added tests to detect this condition but too restrictive in some cases.

Michael Vogt (mvo) on 2010-05-04
description: updated

I can confirm that the Package from #4 is working. Tested a package downgrade successfully.

Accepted synaptic into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Daniel Baumann (dnjl) wrote :

confirm. version 0.63.1ubuntu7 in proposed seems to work for me.

Fabio Marconi (fabiomarconi) wrote :

Not testable for me, Ctrl+E don't do anything and force is unlighted, but acpid is marked for update.

Confirming it works. Even with ctrl+e. Downgrade was possible and successful.

Fabio Marconi (fabiomarconi) wrote :

Confirm, updated acpid, now it work.

Michael Vogt (mvo) wrote :

Three success reports, setting it to verfication-done, many thanks to the testers :)

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.63.1ubuntu7

---------------
synaptic (0.63.1ubuntu7) lucid-proposed; urgency=low

  [ Michael Vogt ]
  * common/rpackageview.cc:
    - silence debug output (thanks to Bob Huffman)

  [ Jean-Baptiste Lallement ]
  * gtk/rgmainwindow.cc, gtk/rgutils.{cc,h}:
    - un/escape markup when getting/setting subviews name to avoid markup
      insertion in GtkTree items (LP: #567172)
  * gtk/rgmainwindow.cc:
    - fix force version. regression over beta2 (LP: #568925)
  * gtk/rgmainwindow.cc:
    - fix double-click doesn't unmark a previously marked for install/upgrade
      package. regression over beta2 (LP: #566779)
 -- Michael Vogt <email address hidden> Tue, 04 May 2010 17:10:50 +0200

Changed in synaptic (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick.

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers