[regression] Synaptic can't select and install "gnome-shell" package / unmet dependency libgjs0

Bug #565816 reported by Maxim Dobriakov on 2010-04-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
synaptic (Ubuntu)
Critical
Jean-Baptiste Lallement
Lucid
Critical
Jean-Baptiste Lallement

Bug Description

Binary package hint: synaptic

Steps for reproduce:
1. Open Synaptic
2. Open Search dialog
3. Type "gnome-shell" and click "Search" button
4. Open context menu for "gnome-shell" package and click "Mark for installation"

Now I see that "gnome-shell" package doesn't change checkbox status (checkbox is clear, but I expect to see checked checkbox)

5. Click "Apply"

Now I see the following error message:
  E: Unable to correct problems, you have held broken packages.
  E: Unable to lock the download directory

I don't have have other open Sinaptic or aptitude instances.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: synaptic 0.63.1ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Apr 18 12:47:26 2010
ExecutablePath: /usr/sbin/synaptic
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic

Related branches

Maxim Dobriakov (closer-main) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

confirmed with latest synaptic. The error message could be better, the check box should be checked (or not then the package shouldn't be upgraded) and in my case, there is an empty list of unauthenticated packages. Setting to triaged/low
However the root cause of the problem is with gnome-shell because of a non installable dependency.
~# apt-get install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-shell: Depends: libgjs0 but it is not going to be installed
E: Broken packages

Changed in synaptic (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Jean-Baptiste Lallement (jibel) wrote :

adding gnome-shell task, for package not being installable in lucid.

Changed in gnome-shell (Ubuntu):
importance: Undecided → High
status: New → Triaged
summary: - Synaptic can't select and install "gnome-shell" package
+ Synaptic can't select and install "gnome-shell" package / unmet
+ dependency libgjs0

This is a regression introduced by fix for bug #513460.

Changed in synaptic (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
importance: Low → High
status: Triaged → In Progress
Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Michael Vogt (mvo) on 2010-04-19
summary: - Synaptic can't select and install "gnome-shell" package / unmet
- dependency libgjs0
+ [regression] Synaptic can't select and install "gnome-shell" package /
+ unmet dependency libgjs0
Michael Vogt (mvo) on 2010-04-19
Changed in synaptic (Ubuntu Lucid):
importance: High → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.63.1ubuntu6

---------------
synaptic (0.63.1ubuntu6) lucid; urgency=low

  [ Jean-Baptiste Lallement ]
  * gtk/rgmainwindow.cc:
    - fix 'broken package installation' regression over beta2 (LP: #565816)
 -- Michael Vogt <email address hidden> Mon, 19 Apr 2010 11:24:00 +0200

Changed in synaptic (Ubuntu Lucid):
status: Fix Committed → Fix Released
Maxim Dobriakov (closer-main) wrote :

Thanks a lot!!! Now I can install gnome-shell without problem.

I mark the task for gnome-shell as invalid, the problem was in the libgjs0 package not in gnome-shell. The problem in gjs has been fixed now (bug #555155) and gnome-shell is installable.

Changed in gnome-shell (Ubuntu Lucid):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers