synaptic shows anonymous dialog if started by non-privileged user

Bug #510261 reported by Per Ångström on 2010-01-20
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: synaptic

If Synaptic is started by a non-privileged user (not using sudo or su), it shows the following text in a caption-less (anonymous) dialog, before the main window is opened:

[quote]
Starting without administrative privileges
You will not be able to apply any changes. But you can still export the marked changes or create a download script for them.
[/quote]

I am irritated by the fact that the dialog is anonymous. It should have a caption so the user can see where it comes from. Furthermore, the only button is labelled "Close". In this context, I think "OK" is the only valid label, although I would welcome a Cancel button, which would close the application immediately.

Admittedly, this dialog should not be seen very often, and then only in an interactive scenario where the user issues the "synaptic" command in a console. However, to me this dialog happened to flash by during a session restore, and then it was very difficult to connect to Synaptic.

Related branches

Per Ångström (autark) wrote :

Screenshot of the offending dialog.

Philip Muškovac (yofel) wrote :

A window Title would be nice indeed.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Jonathan Davies (jpds) on 2010-01-22
Changed in synaptic (Ubuntu):
importance: Undecided → Wishlist
Per Ångström (autark) wrote :

> Importance: Undecided => Wishlist

Hey, this is not a "wish". A dialog without an identifying caption is a
bug, IMO.

Philip Muškovac (yofel) wrote :

Indeed, my fault, corrected.

Changed in synaptic (Ubuntu):
importance: Wishlist → Low
Per Ångström (autark) wrote :

Same behavior in Ubuntu 10.10 RC1.

Changed in synaptic (Ubuntu):
status: Confirmed → Triaged
Dmitri Bachtin (damg) wrote :

Approved for merging, pending as it looks like.

Robert Roth (evfool) wrote :

This doesn't seem to be fixed in Natty.

Robert Roth (evfool) wrote :

Based on the GNOME Human Interface Guidelines[1], which Ubuntu tends to follow (more or less), alert dialogs should not have a title, as it would be duplicating the primary text. Based on this I tend to mark this bug as Invalid. What do you think? Or maybe Opinion would be a better status?

[1] http://developer.gnome.org/hig-book/3.0/windows-alert.html.en
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in synaptic (Ubuntu):
status: Triaged → Incomplete

Fair enough, as long as the dialog text makes clear that it comes from
Synaptic.

Robert Roth (evfool) wrote :

You're right, as this is not the standard case of an alert (popped up in front of an application by that application), but an alert shown before the app is started. So I have changed the primary text to "Starting "Synaptic Package Manager" without administrative privileges" .
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in synaptic (Ubuntu):
status: Incomplete → Confirmed
assignee: nobody → Robert Roth (evfool)
status: Confirmed → In Progress
Robert Roth (evfool) on 2012-07-13
Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed

Would be near perfection:

If it would also

recommend the usage of 'gksu' or 'kdesudo'

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp1

---------------
synaptic (0.80~exp1) experimental; urgency=low

  [ Robert Roth ]
  * * Disables typeahead in summary dialog, as it doesn't do anything,
    so it's unnecesary (LP: #24319)
  * Move up and Move down buttons in columns preferences changed to
    respect buttons_have_icons preference (LP: #66574)
  * Set the title of the package properties dialog opened for the first
    time (it has not been set before, so it was synaptic the first time
    the dialog has been opened) (LP: #932495)
  * Added a reload button to the repositories changed dialog (LP: #78987)
  * Updated the wording of the expander on the download progress dialog to
    Show individual files" instead of "Show for individual files"
    (LP: #301428)
  * Fixed inconsistencies between column namings in column headers and
    column visibility preferences (LP: #335723)
  * Linkified maintainer label in the package properties dialog
    when running as non-root (LP: #321380)
  * Added package name in the warning scaring you about breaking your
    system (LP: #63974)
  * Added name of the application (Synaptic Package Manager) in the
    titleless dialog shown when starting without administrative
    privilegess (LP: #510261)
  * Improved filter editing checkbox tooltips (LP: #790420)
  * Made all the property values from the package properties dialog
    selectable (LP: #173464)
  * Changed Package Properties accelerator from Ctrl+O to widely used
    (nautilus, eog, evince etc) Alt+Enter (LP: #933554)
  * Use the synaptic icon from the user's icon theme, or fall back to
    the old one if the current theme does not provide a synaptic icon
    (LP: #153755)
  * Focus the Apply button by default. (LP: #488718)
  * Removed log message from automatically installed item click
    (LP: #883984)
  * Fixed delete filter button not working caused by a typo in the
    name of the button when getting it from the GtkBuilder object
    (LP: #779756)
  * Added suggests tasksel as with tasksel installed synaptic
    provides additional functionality (LP: #605186)
  * Fixes incorrect radiobutton handling in the proxy preferences
    (LP: #706262)
  * Fixed incorrect status message when canceling 'Mark all available
    upgrades' feedback dialog (LP: #975578)

  [ Michael Vogt ]
  * ensure external helpers are runs as the user uid
  * build for gtk3 and update build-depends
  * move software-propoerties-gtk into suggests
  * strip strings properly in a markings file, thanks to
    Vassilis Palassopoulos (palasso)
  * show source package name in the details (closes: #692528)
  * merged lp:~fitoschido/synaptic/es-redundancy:
    - Remove empty es_ES .po files. Spanish translations are already
      provided in es files. Thanks to Adolfo Jayme Barrientos (fitoschido)
  * common/rpackagelister.cc:
    - add support for complete removal (purge) in the markings file

 -- Michael Vogt <email address hidden> Thu, 13 Dec 2012 10:08:37 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers