Improper Tabbing and Arrow keying in Quick Search of synaptic

Bug #502582 reported by MarkH on 2010-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Jean-Baptiste Lallement

Bug Description

Binary package hint: synaptic

Although, once you start tabbing in Synaptic Package Manager (0.62.5) (9.10)
and you SHIFT-TAB from the main left-sidebar listing,
and you press either/only the UP-ARROW or the LEFT-ARROW keys,
the cursor-blinking-prompt-thing (finally) shows up,
then you can finally start entering your quick search tag/term.

(You can also get to the Quick search field by tabbing twice from the 'Get Screenshot' button,
when a package is selected, and holding the LEFT-ARROW key or pressing the DOWN-ARROW a couple times, then it disappears.)

Also, once in the Quick Search field,
pressing DOWN or UP (arrow keys) takes you 'out' of the field and somewhere else along the bar/field?
Pressing DOWN you only then have to press UP-ARROW once to make it appear in the field again,
and pressing the UP-ARROW once you press the DOWN-ARROW to get back. Plus however
many times you press UP-ARROW, you have to press the DOWN-ARROW twice to get 'back in' the field.

This moving around isn't too annoying, just something that probably should act more like, let's say, Evolution...
...in-terms of the movement through the keyboard, yes. Thanks for reading!

ProblemType: Bug
Architecture: i386
Date: Sun Jan 3 06:02:52 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/sbin/synaptic
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
LiveMediaBuild: Debian GNU/Linux testing "Lenny" - Official Snapshot amd64 LIVE Binary 20080715-13:41
NonfreeKernelModules: nvidia
Package: synaptic 0.62.7ubuntu6
ProcEnviron:
 LANGUAGE=en_CA.UTF-8
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: synaptic
Uname: Linux 2.6.31-16-generic i686
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2124): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (xfce4-mixer-plugin:2175): libxfce4mixer-CRITICAL **: xfce_mixer_get_track: assertion `GST_IS_MIXER (card)' failed
 (xfce4-terminal:2202): Terminal-WARNING **: Unable to load terminal preferences.

Related branches

MarkH (mhenderson) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in synaptic (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: quicksearch
Jean-Baptiste Lallement (jibel) wrote :

That's because the text entry is part of the toolbar and tab moves between widget and not between toolbar's button (arrows are used for that)
Working on it.

Changed in synaptic (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
status: Triaged → In Progress
Jean-Baptiste Lallement (jibel) wrote :

Fix committed to my branch.

Not perfect yet but improved.

Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.63.1ubuntu10

---------------
synaptic (0.63.1ubuntu10) maverick; urgency=low

  [ Michael Vogt ]
  * po/uk.po:
    - updated, thanks to Serhij Dubyk

  [ Jean-Baptiste Lallement ]
  * Fix sorting issues of the package list
    - Fix sort by name and by section (LP: #518509)
    - Improve sort by column performance
  * sort 'installed files' list in alphabetical order (LP: #32550)
  * Set version labels selectable in package properties (LP: #76568)
  * disable 'Lock Version' and 'Automatically installed' menu entries for a
    normal user (LP: #309906)
  * common/rpackagelister.cc:
    - in RPackageLister::xapianSearch() catch xapian exception to
      prevent crash when xapian interprets search string as a syntax
      error
    - fix sorting in xapian search mode (LP: #508220)
  * gtk/gsynaptic.cc
    - Start with focus set on fast search entry (LP: #326155)
  * Select first subview on view change (LP: #403165)
  * Fix Gtk-CRITICAL when the fast search entry is cleared (LP: #385739)
  * Ignore DEL accelerator when fast search has focus (LP: #294178)
  * Do not start help viewer as root but as SUDO_USER (LP: #110224)
  * wrap lines in textarea of dialog_update_failed (LP: #237455)
  * set textarea read-only in generic error dialog (LP: #403100)
  * Change 'Icon Legend' dialog to fixed size (LP: #374376)
  * add tooltip to 'properties' and 'search' buttons (LP: #202681)
  * gtk/glade/window_main.glade:
    - put the fastsearch entry out of the toolbar (LP: #502582)
    - move the fastsearch entry to the upper-right (LP: #290524)
  * gtk/rgfetchprogress.cc:
    - change "Download rate: unknown" to "Download rate: ..."
      (LP: #393358)
  * Sort by relevancy when doing quicksearch and no search column is set.
 -- Michael Vogt <email address hidden> Mon, 21 Jun 2010 13:12:54 +0200

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers