Ubuntu

Installed Size column checked by default, but not visible

Reported by Hew McLachlan on 2009-02-28
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: synaptic

On a fresh install of Ubuntu (or a LiveCD), synaptic does not display the Installed Size column. However, looking in Settings -> Preferences -> Columns & Fonts shows that this column is already selected. Adding or removing other columns and then applying the changes causes the Installed Size column to correctly become visible.

Reproduced with synaptic 0.62.5ubuntu1 on Jaunty, but this has been present in previous Ubuntu releases for as long as I can remember.

Steps to reproduce:
1) Use a LiveCD or fresh install of Ubuntu. Column settings must not have been previously modified.
2) Open Synaptic, and notice that the Installed Size ("Size") column is not visible.
3) Settings -> Preferences -> Columns & Fonts.
4) Modify the visible columns (eg. add Download Size) and select OK.

What should happen:
Installed Size column should be visible to start with.

What actually happens:
Installed Size column is not visible until above steps are followed.

Hew McLachlan (hew) on 2009-02-28
Changed in synaptic:
importance: Undecided → Low
Daniel (dant) wrote :

Marking as confirmed. I was able to reproduce this after a fresh install of karmic

Changed in synaptic (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Confirmed in lucid.

'Installed size' and 'available version' are checked in preferences but not shown.

Changed in synaptic (Ubuntu):
status: Confirmed → Triaged
Robert Roth (evfool) wrote :

The real problem here is the inconsistencies between the preferences column headers, as Installed size in preferences refers to the column with the Size column header, and Available version in preferences is Latest version in the headers.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Robert Roth (evfool) on 2012-02-16
Changed in synaptic (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Vit Svarc (vs-pb) wrote :

The same in 12.04. It is enough to open preferences and close it, then the column will magically appear.

Robert Roth (evfool) on 2012-07-13
Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Hew McLachlan (hew) wrote :

Any progress on this? Still present in 12.10.

Changed in synaptic (Ubuntu):
status: Fix Committed → Triaged
Robert Roth (evfool) wrote :

The fix is committed into the trunk of synaptic, but there has been no release since. When the next release of synaptic will be uploaded, it will get Fix released, but now it is only committed.

Changed in synaptic (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp1

---------------
synaptic (0.80~exp1) experimental; urgency=low

  [ Robert Roth ]
  * * Disables typeahead in summary dialog, as it doesn't do anything,
    so it's unnecesary (LP: #24319)
  * Move up and Move down buttons in columns preferences changed to
    respect buttons_have_icons preference (LP: #66574)
  * Set the title of the package properties dialog opened for the first
    time (it has not been set before, so it was synaptic the first time
    the dialog has been opened) (LP: #932495)
  * Added a reload button to the repositories changed dialog (LP: #78987)
  * Updated the wording of the expander on the download progress dialog to
    Show individual files" instead of "Show for individual files"
    (LP: #301428)
  * Fixed inconsistencies between column namings in column headers and
    column visibility preferences (LP: #335723)
  * Linkified maintainer label in the package properties dialog
    when running as non-root (LP: #321380)
  * Added package name in the warning scaring you about breaking your
    system (LP: #63974)
  * Added name of the application (Synaptic Package Manager) in the
    titleless dialog shown when starting without administrative
    privilegess (LP: #510261)
  * Improved filter editing checkbox tooltips (LP: #790420)
  * Made all the property values from the package properties dialog
    selectable (LP: #173464)
  * Changed Package Properties accelerator from Ctrl+O to widely used
    (nautilus, eog, evince etc) Alt+Enter (LP: #933554)
  * Use the synaptic icon from the user's icon theme, or fall back to
    the old one if the current theme does not provide a synaptic icon
    (LP: #153755)
  * Focus the Apply button by default. (LP: #488718)
  * Removed log message from automatically installed item click
    (LP: #883984)
  * Fixed delete filter button not working caused by a typo in the
    name of the button when getting it from the GtkBuilder object
    (LP: #779756)
  * Added suggests tasksel as with tasksel installed synaptic
    provides additional functionality (LP: #605186)
  * Fixes incorrect radiobutton handling in the proxy preferences
    (LP: #706262)
  * Fixed incorrect status message when canceling 'Mark all available
    upgrades' feedback dialog (LP: #975578)

  [ Michael Vogt ]
  * ensure external helpers are runs as the user uid
  * build for gtk3 and update build-depends
  * move software-propoerties-gtk into suggests
  * strip strings properly in a markings file, thanks to
    Vassilis Palassopoulos (palasso)
  * show source package name in the details (closes: #692528)
  * merged lp:~fitoschido/synaptic/es-redundancy:
    - Remove empty es_ES .po files. Spanish translations are already
      provided in es files. Thanks to Adolfo Jayme Barrientos (fitoschido)
  * common/rpackagelister.cc:
    - add support for complete removal (purge) in the markings file

 -- Michael Vogt <email address hidden> Thu, 13 Dec 2012 10:08:37 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers