quick search focus not automatic on starting Synaptic

Bug #326155 reported by Tom on 2009-02-06
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Dries Harnie
synaptic (Ubuntu)
Undecided
Jean-Baptiste Lallement

Bug Description

Binary package hint: synaptic

Wishlist item

When opening Synaptic typing isn't automatically placed into the Quick Search tool. This means it's actually quicker for me to click on the normal search button so the name "Quick Search" is a bit misleading ;)

To reproduce this try opening Synaptic and start typing = all typing is lost

Also reproduce this by waiting until Synaptic has fully loaded and then try typing. Still nothing. You have to click into the quick search space and then start typing

lol, regards from
Tom :)

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/sbin/synaptic
NonfreeKernelModules: fglrx
Package: synaptic 0.62.1ubuntu10
ProcAttrCurrent: unconfined
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
Uname: Linux 2.6.27-11-generic i686

Related branches

Tom (tom6) wrote :
Changed in hundredpapercuts:
status: New → Confirmed
Tom (tom6) wrote :

Thanks David :)

Changed in hundredpapercuts:
milestone: none → round-7
Paul Elms (scifly) on 2009-07-15
Changed in synaptic (Ubuntu):
status: New → Confirmed
Vish (vish) wrote :

@David Siegel:

Since synaptic is going to be replaced by Appcenter, why is this a papercut?
Rather a papercut which is useful in the long run, can replace this in the Karmic cycle.

Tom (tom6) wrote :

Oh no! Apart from that synaptic is great!

Vish (vish) wrote :

Synaptic is nice, but Appcenter will have more features> https://wiki.ubuntu.com/AppCenter

@mac_v

AFAIK mpt is targeting to replace Synaptic in the 10.04 release. Fixing this papercut would be beneficial to all Synaptic users even after removing Synaptic.

Vish (vish) wrote :

@zekopeko:
I think you got me wrong, I'm not saying dont fix this.
Michael Vogt is very interested in maintaining synaptic. and he knows that synaptic will have a lot of users even if it is not part of the default install. So this will be fixed in the synaptic project.

But for papercut project, since this is being replaced in the karmic+1, IMO, we need to focus on things that have benefit on the long run something that will be effective in atleast more than 1 future release. Papercuts benefiting the LTS is better.
There are so many more papercuts which have not been scheduled for Karmic.

@mac_v

I did misunderstood you. Then this bug should be forwarded to the synaptic team and replaced with a better paper cut.

Dries Harnie (dharnie) wrote :

Papercut or not, attached is a patch that focuses the fast search field when synaptic starts up.

Changed in synaptic (Ubuntu):
assignee: nobody → Dries Harnie (dharnie)
Changed in hundredpapercuts:
assignee: nobody → Dries Harnie (dharnie)
Dries Harnie (dharnie) on 2009-08-07
Changed in hundredpapercuts:
status: Confirmed → In Progress
Changed in synaptic (Ubuntu):
status: Confirmed → In Progress
Tom (tom6) wrote :

Brilliant, nicely done :)))
Thanks for that :))
Regards from
Tom :)

Synaptic is being superseded by the AppCenter in Karmic, so this no longer qualifies as a paper cut (does not affect the default experience).

Changed in hundredpapercuts:
milestone: round-7 → none
status: In Progress → Invalid
tags: added: patch
tags: added: quicksearch
Nigel Babu (nigelbabu) wrote :

@Dries Could you forward this patch to debian?

tags: removed: patch
tags: added: patch-needswork
Dries Harnie (dharnie) wrote :

Nigel: I downloaded the debian package to see if the patch applies, but according to this debian bugreport (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=552588) their version of synaptic does not have a quick-search field (yet).

I see no reason why the ubuntu patch shouldn't apply, though.

Thanks for providing that patch Dries.

I've committed a one liner fix to my branch and pending for approval.
Thanks for your help.

Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
assignee: Dries Harnie (dharnie) → Jean-Baptiste Lallement (jibel)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.63.1ubuntu2

---------------
synaptic (0.63.1ubuntu2) lucid; urgency=low

  [ Michael Vogt ]
  * po/uk.po:
    - updated, thanks to Serhij Dubyk
  * build from the lp:~ubuntu-core-dev/synaptic/lucid branch

  [ Jean-Baptiste Lallement ]
  * Fix sorting issues of the package list
    - Fix sort by name and by section (LP: #518509)
    - Improve sort by column performance
  * sort 'installed files' list in alphabetical order (LP: #32550)
  * Set version labels selectable in package properties (LP: #76568)
  * disable 'Lock Version' and 'Automatically installed' menu entries for a
    normal user (LP: #309906)
  * common/rpackagelister.cc:
    - in RPackageLister::xapianSearch() catch xapian exception to
      prevent crash when xapian interprets search string as a syntax
      error
    - fix sorting in xapian search mode (LP: #508220)
  * gtk/gsynaptic.cc
    - Start with focus set on fast search entry (LP: #326155)
  * Select first subview on view change (LP: #403165)
  * Fix Gtk-CRITICAL when the fast search entry is cleared (LP: #385739)
  * Ignore DEL accelerator when fast search has focus (LP: #294178)
  * Do not start help viewer as root but as SUDO_USER (LP: #110224)
  * wrap lines in textarea of dialog_update_failed (LP: #237455)
  * set textarea read-only in generic error dialog (LP: #403100)
  * Change 'Icon Legend' dialog to fixed size (LP: #374376)
 -- Michael Vogt <email address hidden> Tue, 16 Feb 2010 11:13:45 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released

Well, we're still shipping Synaptic so let's count this as a fixed paper cut for Lucid.

Changed in hundredpapercuts:
status: Invalid → Fix Released
Tom (tom6) wrote :

Brilliant, good work all. Thanks for fixing this for me :)

Many regards from
Tom :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.