there's no GUI way to copy text from the embedded terminal window (middle-click works)

Bug #31396 reported by Chris Moore on 2006-02-14
14
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Wishlist
Jean-Baptiste Lallement

Bug Description

I was just trying to respond to a comment on bug 29774 ( https://launchpad.net/distros/ubuntu/+source/update-manager/+bug/29774 ) and wanted to copy some text from the terminal window which shows the progress of applying updates.

There's no right-click context menu, so I couldn't 'copy' in that way, so I hightlighted the text I wanted and pressed control-c, which I thought might copy the text. Instead, it aborted the question, and caused the update to fail.

Could control-c be set to 'copy' rather than 'interrupt' in the embedded terminal window?

Related branches

Changed in update-notifier:
assignee: nobody → mvo
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

You can copy'n'paste the text by selecting it with the left mouse button and paste it into other windows with the middle mouse button.

A right-click menu with copy/paste etc would certainly be nicer though.

Cheers,
 Michael

Changed in update-notifier:
status: Unconfirmed → Confirmed
jonatan84 (jjalfin2) wrote :

You can also copy, by doing CTRL-SHIFT-C and similarly paste by doing CTRL-SHIFT-V

Connor Imes (ckimes) wrote :

I am going to mark this as a duplicate of bug 250359 since there is more and up-to-date discussion there. It will probably be Wishlisted due to no middle mouse button emulation in KDE.

Connor Imes (ckimes) wrote :

Disregard previous comment, I will do it the other way around since this bug already has a duplicate.

Please see bug 250359 for more discussion on this topic.

I am going to Wishlist this bug - people would like to be able to use the right mouse click in the embedded terminal, or perhaps have a Copy button in the window.

Changed in synaptic:
importance: Low → Wishlist
JM Williams (jmdwilliams) wrote :

Note that Ctrl+Shift+C does not currently copy from the embedded terminal
window in Synaptic (see comments in bug 250359).

If you want a keyboard workaround, try Ctrl+Insert.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

tags: added: terminal
Changed in synaptic (Ubuntu):
status: Confirmed → Triaged
Jean-Baptiste Lallement (jibel) wrote :

Committed to bzr lp:~jibel/synaptic/bug.250359.31396 revno 99
I've added a popup menu to the terminal with the actions 'copy' and 'select all'. I haven't found a useful use case for the 'paste' action.

Changed in synaptic (Ubuntu):
assignee: Michael Vogt (mvo) → Jean-Baptiste Lallement (jibel)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package synaptic - 0.70~pre2ubuntu1

---------------
synaptic (0.70~pre2ubuntu1) natty; urgency=low

  * merged from debian/unstable, remaining changes:
    - ubuntu icons for supported applications
    - launchpad-integration
    - ubuntu changelog download support
    - support section metapackages
    - x-ubuntu-gettext-domain in desktop file

synaptic (0.70~pre2) unstable; urgency=low

  [ Michael Vogt ]
  * po/pt_BR.po:
    - updated, thanks to Sergio Cipolla (closes: #593758)
  * po/id.po:
    - added, thanks to Dirgita
  * po/ru.po:
    - updated, thansk to Yuri Kozlov (closes: #571712)
  * po/de.po:
    - fix fuzzy string, thanks to Alek (closes: #599744)
  * po/et.po:
    - updated, thanks to Guido Tabbernuk
  * po/he.po:
    - updated, thanks to Lior Kaplan and Sergio Cipolla
      (closes: #586940)
  * gtk/rgdebinstallprogress.cc, gtk/rgterminstallprogress.cc:
    - fix FTBFS on latest vte (closes: #597384)
  * common/rpackagecache.{cc,h}, common/rpackage.cc:
    - add cache for PkgFileIterator->pkgIndexFile* to speed up
      RPackage::IsTrusted (LP: #165181)
  * gtk/rgdebinstallprogress.cc:
    - merge fix for error string if those contain a ":"
      (LP: #600658), thanks to Jonathan Thomas and Jean-Baptiste Lallement
  * common/rpackagelister.cc:
    - when sorting by support status use STL stable_parition to speed
      up the list view (thanks to David Purcell)
    - when clicking on the "supported" column, default to showing the
      supported items first, then the unsupported ones
  * gtk/rgmainwindow.cc:
    - show message in quick search label if no apt-xapian-index can
      be found

   [ Jean-Baptiste Lallement ]
   * gtk/rgdebinstallprogress.{cc,h}: Terminal shortcuts fixes
     - fix <CTRL><SHIFT>c behavior (LP: #250359)
     - add shortcuts <CTRL>a and <CTRL><SHIFT>a to select all/none text
       in the terminal
     - add contextual menu to the terminal to select all and copy text
       (LP: #31396)

synaptic (0.70~pre1) unstable; urgency=low

  * New upstream release that merges all changes from
    Debian and Ubuntu into a single tree again. This include libept
    support and lots of fixes.
  * po/sl.po:
    - updated, thanks to Matej Urbančič
  * po/pt_BR.po:
    - updatd, thanks to Sergio Cipolla, closes: #579296
  * gtk/rgmainwindow.cc:
    - fix hang when applying the preferences (LP: #172487)
  * po/th.po:
    - updated, thanks to Theppitak Karoonboonyanan
      (closes: #592696)
  * pre-build.sh:
    - ensure version number gets updated on build

synaptic (0.63.2) unstable; urgency=low

  [ Michael Vogt ]
  * po/uk.po:
    - updated, thanks to Serhij Dubyk
  * po/it.po:
    - updated, thanks to Milo Casagrande (closes: #575685)
  * po/et.po:
    - added, thanks to G. Tabbernuk

  [ Bilal Akhtar ]
  * gtk/rgmainwindow.cc
    - Modify gtk/rgmainwindow.cc to populate package list again after
     'Unmark All' is selected. (LP: #155930)

  [ Jean-Baptiste Lallement ]
  * Fix sorting issues of the package list
    - Fix sort by name and by section (LP: #518509)
    - Improve sort by column performance
  * sort 'installed files' list in alphabetical order (LP: #32550)
  * Set versi...

Read more...

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers