Ubuntu

Synaptic package manager just showing installed app when using search function

Reported by izlan on 2008-11-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

Im using Ubuntu 8.10 and when searching package to install in Synaptic package manager, its only show package that i already installed. I need to browse it one by one rather than using search function

Go to Settings → Filters → Search Filter and make you sure you have enabled "Not installed packages" (for more info see attached screenshot).

Changed in synaptic:
status: New → Incomplete
JasonSpradlin82 (jaspradlin) wrote :

I am having this same problem, and "Not Installed packages" is enabled under search filter. The ONLY way to find not installed packages is to NOT search, and scan through the list manually -- this is bothersome if I don't know what I'm looking for an need the search to help

Ben Straton (fanum) wrote :

I also have "Not installed packages" selected with no results. I am using 9.04 alpha 5 on a amd64. For me, the quick search only shows installed packages, regardless of number of letters entered, but the search feature will work for one letter searches only,

Ben Straton (fanum) wrote :

Found a Solution:

Close synaptic

sudo update-apt-xapian-index

Sunny Brown (skoondi) wrote :

Thanks for the solution Ben, that worked for me. I had the same error on a clean install of 8.10 amd64, I had already used the same media for an install on a different machine and I did not have this problem. I see that this bug is marked to expire because it is incomplete that would be unfortunate as it still seems to be a problem and this solution was useful.

Pac Shady (pacshady) wrote :

I also have the same problem, just switched from Kubuntu and found Synaptic doesn't let me search not-installed packages even when it's been told to. Ben's solution worked though :)

Question though, does that command need to be run EVERY TIME I update repositories, or will just the once work?

Just once should do it. If it is a reacurring issue post you results
here an we can look into it.

Sent from my iPhone

On Mar 27, 2009, at 8:34 PM, Pac Shady <email address hidden> wrote:

> I also have the same problem, just switched from Kubuntu and found
> Synaptic doesn't let me search not-installed packages even when it's
> been told to. Ben's solution worked though :)
>
> Question though, does that command need to be run EVERY TIME I update
> repositories, or will just the once work?
>
> --
> Synaptic package manager just showing installed app when using
> search function
> https://bugs.launchpad.net/bugs/294522
> You received this bug notification because you are a direct subscriber
> of the bug.

Ben Straton (fanum) wrote :

not sure if this workaround is a permanent solution. Can someone set this to be done automatically after installing or after the first apt-get update? It would only add a few seconds to the install for users unaffected by this issue and solve it for the rest.

Changed in synaptic:
status: Incomplete → In Progress
Ben Straton (fanum) wrote :

I have marked this as in progress to keep it from expiring, untill the
underlying cause is fixed or this solution is adapted by default.
Thanks Sunny for pointing that out.

Sent from my iPhone

On Mar 27, 2009, at 8:04 PM, Sunny Brown <email address hidden> wrote:

> Thanks for the solution Ben, that worked for me. I had the same
> error on
> a clean install of 8.10 amd64, I had already used the same media for
> an
> install on a different machine and I did not have this problem. I see
> that this bug is marked to expire because it is incomplete that
> would be
> unfortunate as it still seems to be a problem and this solution was
> useful.
>
> --
> Synaptic package manager just showing installed app when using
> search function
> https://bugs.launchpad.net/bugs/294522
> You received this bug notification because you are a direct subscriber
> of the bug.

Russell (russellp) wrote :

Just hit this one with a fresh 9.04 install. Strange, as every other install of 9.04 I've done _worked_.

Ben's fix, however, doesn't help in this instance - I still only see packages that are installed when using quicksearch.

Using single-letter "full" searches "works" (as in I get packages that aren't installed, but searching using only a single letter is next to useless).

I can't reproduce it in karmic or lucid. Could you please try with a newer release and report here. Thanks.

Changed in synaptic (Ubuntu):
status: In Progress → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".
Thanks again!

Changed in synaptic (Ubuntu):
status: Incomplete → Invalid
meksONE (meksone) wrote :

Same bug on a fresh install of Lucid on a Lenovo ThinkPad R61e (model DNG 7650).
I have only installaed Italian Support and removed English Language... may this can be the problem?

Changed in synaptic (Ubuntu):
status: Invalid → New
meksONE (meksone) wrote :

The command sudo update-apt-xapian.index doesn't work, but if you add a "-f" option, it do the magic.
I've installed Lucid many times on different hardwares, this is the first time... Maybe a Lenovo (or it's hardware) issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers