Unable to use Del key for editing text in Synaptic

Bug #294178 reported by Dmitry Kann on 2008-11-05
98
This bug affects 13 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
synaptic (Ubuntu)
Medium
Jean-Baptiste Lallement

Bug Description

Binary package hint: synaptic

When I select some text typed e.g. in Quick search edit field, and then press Del to delete it, the application handles this as if I wanted to delete selected packages instead.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/sbin/synaptic
Package: synaptic 0.62.1ubuntu10
ProcAttrCurrent: unconfined
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
Uname: Linux 2.6.27-7-generic i686

Related branches

Dmitry Kann (yktooo) wrote :
Ameen Demidem (ameen.demidem) wrote :

Was quite hard to reproduce.
Do as follows :
1- Select an installed package
2- Click on quick search
3- Press Del

It behaves as if the pane showing the packages had the focus no matter whether the Quick search input box contains text already or not.
What's even strange is that if the currently selected package is not installed it behaves the way it should.

Changed in synaptic:
status: New → Confirmed
Vish (vish) wrote :

Thank you for bringing this bug to our attention.

Synaptic is being replaced by AppCentre in 9.10 , Hence not a papercut issue. https://wiki.ubuntu.com/AppCenter

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read >
https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
AsstZD (eskaer-spamsink) wrote :

Still present today, at 0.62.5

Jean-Baptiste Lallement (jibel) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in synaptic (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: quicksearch
Changed in synaptic (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
status: Triaged → In Progress
Jean-Baptiste Lallement (jibel) wrote :

Fix committed to my branch

Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.63.1ubuntu2

---------------
synaptic (0.63.1ubuntu2) lucid; urgency=low

  [ Michael Vogt ]
  * po/uk.po:
    - updated, thanks to Serhij Dubyk
  * build from the lp:~ubuntu-core-dev/synaptic/lucid branch

  [ Jean-Baptiste Lallement ]
  * Fix sorting issues of the package list
    - Fix sort by name and by section (LP: #518509)
    - Improve sort by column performance
  * sort 'installed files' list in alphabetical order (LP: #32550)
  * Set version labels selectable in package properties (LP: #76568)
  * disable 'Lock Version' and 'Automatically installed' menu entries for a
    normal user (LP: #309906)
  * common/rpackagelister.cc:
    - in RPackageLister::xapianSearch() catch xapian exception to
      prevent crash when xapian interprets search string as a syntax
      error
    - fix sorting in xapian search mode (LP: #508220)
  * gtk/gsynaptic.cc
    - Start with focus set on fast search entry (LP: #326155)
  * Select first subview on view change (LP: #403165)
  * Fix Gtk-CRITICAL when the fast search entry is cleared (LP: #385739)
  * Ignore DEL accelerator when fast search has focus (LP: #294178)
  * Do not start help viewer as root but as SUDO_USER (LP: #110224)
  * wrap lines in textarea of dialog_update_failed (LP: #237455)
  * set textarea read-only in generic error dialog (LP: #403100)
  * Change 'Icon Legend' dialog to fixed size (LP: #374376)
 -- Michael Vogt <email address hidden> Tue, 16 Feb 2010 11:13:45 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

Since synaptic is still there in lucid, this can be considered as a fixed papercut in lucid.

Changed in hundredpapercuts:
status: Invalid → Fix Released

Jean-Baptiste, I don't want to count this towards 100 paper cuts for Lucid because it's a corner case that doesn't affect many users.

Changed in hundredpapercuts:
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers