[quicksearch] Move the quick search box to the upper right

Bug #290524 reported by Fred on 2008-10-29
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Jean-Baptiste Lallement

Bug Description

Now the searchbar in Synaptic looks kinda messy and out-of-place.

Move the searchbar in Synaptic to the right, just like it is located in Mozilla Firefox and many other applications.

So that the user finds and expects it in the same location. This will increase usability and ease-of-use, and make things feel more consistent.
It will also look much prettier and well thought-out.

Related branches

Fred (eldmannen+launchpad) wrote :
Fred (eldmannen+launchpad) wrote :
description: updated

Confirmed. It's a universal rule that search boxes belong on the top-right of an application (unless they are the main focus of the app.)

Look at this Web site for example, or the Apple HIG has a reference screenshot of Finder: http://developer.apple.com/documentation/UserExperience/Conceptual/AppleHIGuidelines/XHIGControls/chapter_19_section_6.html#//apple_ref/doc/uid/TP30000359-TPXREF210

Or there's the GNOME library site with it's search box on the top-right: http://library.gnome.org/
Transmission has its search box on the right, as does Thunderbird, and Evolution.

This rule should probably be added to the GNOME HIG: http://library.gnome.org/devel/hig-book/stable/

Jean-Baptiste Lallement (jibel) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in synaptic (Ubuntu):
importance: Undecided → Low
status: New → Triaged
summary: - Move searchbar in Synaptic
+ Move the quick search box to the upper right
summary: - Move the quick search box to the upper right
+ [quicksearch] Move the quick search box to the upper right
tags: added: quicksearch
Changed in synaptic (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
status: Triaged → In Progress
Jean-Baptiste Lallement (jibel) wrote :

Commited to my branch.

I moved the search button too, to keep search functions together.
Comments welcome.

Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Sergey Kirienko (skirienko) wrote :

I think that having search field and Search button with dialog is a bit confusing.

Is there a way to have universal quick search? I mean, is it possible technically to search quickly through all packages? If it is, it's better to focus on one quick search and get rid of the dialog.

Jean-Baptiste Lallement (jibel) wrote :

Indeed, having a unified search box and get rid of the search button would be great. But it means a complete refactoring of the search functionality (add to the index the missing fields, change the entry field to something like a combo, rework the search filters, ...). Secondly, debian only have the standard search. And thirdly synaptic will be superseded by software-center in 10.10 .
So, I don't think it's worth it.
But that's only my opinion.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.63.1ubuntu10

---------------
synaptic (0.63.1ubuntu10) maverick; urgency=low

  [ Michael Vogt ]
  * po/uk.po:
    - updated, thanks to Serhij Dubyk

  [ Jean-Baptiste Lallement ]
  * Fix sorting issues of the package list
    - Fix sort by name and by section (LP: #518509)
    - Improve sort by column performance
  * sort 'installed files' list in alphabetical order (LP: #32550)
  * Set version labels selectable in package properties (LP: #76568)
  * disable 'Lock Version' and 'Automatically installed' menu entries for a
    normal user (LP: #309906)
  * common/rpackagelister.cc:
    - in RPackageLister::xapianSearch() catch xapian exception to
      prevent crash when xapian interprets search string as a syntax
      error
    - fix sorting in xapian search mode (LP: #508220)
  * gtk/gsynaptic.cc
    - Start with focus set on fast search entry (LP: #326155)
  * Select first subview on view change (LP: #403165)
  * Fix Gtk-CRITICAL when the fast search entry is cleared (LP: #385739)
  * Ignore DEL accelerator when fast search has focus (LP: #294178)
  * Do not start help viewer as root but as SUDO_USER (LP: #110224)
  * wrap lines in textarea of dialog_update_failed (LP: #237455)
  * set textarea read-only in generic error dialog (LP: #403100)
  * Change 'Icon Legend' dialog to fixed size (LP: #374376)
  * add tooltip to 'properties' and 'search' buttons (LP: #202681)
  * gtk/glade/window_main.glade:
    - put the fastsearch entry out of the toolbar (LP: #502582)
    - move the fastsearch entry to the upper-right (LP: #290524)
  * gtk/rgfetchprogress.cc:
    - change "Download rate: unknown" to "Download rate: ..."
      (LP: #393358)
  * Sort by relevancy when doing quicksearch and no search column is set.
 -- Michael Vogt <email address hidden> Mon, 21 Jun 2010 13:12:54 +0200

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
Fred (eldmannen+launchpad) wrote :

I can confirm that the quicksearchbar has been moved in 0.63.1ubuntu10 in maverick.

However, I think the "Quick search" label could be removed, as Firefox, Thunderbird, Transmission etc don't have any such label to describe the bar.

Also, since the search button was moved to the right, but it should probably stay to the left with the other toolbar icons.

My screenshot (After) makes it look better than the current solution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers