In embedded terminal Ctrl+Shift+C should copy not send an interrupt signal

Bug #250359 reported by Philip Ashmore on 2008-07-21
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Undecided
Jean-Baptiste Lallement

Bug Description

Binary package hint: synaptic

lsb_release -d => Ubuntu 8.04.1
KDE 3.5.9

I looked at

https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/31396
there's no GUI way to copy text from the embedded terminal window (middle-click works)

This didn't work for me.
Maybe I'm missing something - I see "Successfully applied all changes. You can close this window now." at the bottom of the terminal window.
Although I can select text with the mouse,. <Ctrl+Shift>C doesn't work.

I would try a middle mouse click but I can't do that either.

https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/250358
KDE No middle mouse button simulation with two button mouse

Related branches

JM Williams (jmdwilliams) wrote :

The summary says that you cannot select text in the terminal window, but the
description says that you can. If you can select text, try to copy it with
Ctrl+Insert. This works for me in GNOME, so you may have success in KDE.

Ctrl+Insert is one of the old-school trio of:

    • Cut: Shift+Delete
    • Copy: Ctrl+Insert
    • Paste: Shift+Insert

I agree that Ctrl+Shift+C “ought” to work for consistency with the GNOME
Terminal emulator (and perhaps other programs), so if the above works for you,
you could maybe rework this bug report as a simple feature request. (Only
trivial feature requests are supposed to be tracked in Launchpad Bugs, so if
this is more than trivial, it would be better off in Launchpad Blueprints or
Ubuntu Brainstorm, for example!)

I’ll mark this bug as Incomplete till you have responded.

Changed in synaptic:
status: New → Incomplete
Connor Imes (ckimes) wrote :

I could not reproduce this Synaptic bug either (using Gnome).

Ctrl+Insert works in KDE 3.5.9!

I wish I knew about this two days ago.

>> Only trivial feature requests are supposed to be tracked in Launchpad Bugs, so if this is more than trivial, it would be better off in Launchpad Blueprints or Ubuntu Brainstorm, for example!

1. Is not being able to select and copy text trivial? Are usability bugs trivial? I had to type out 59 words for another report because I couldn't copy the text from the window.

2. Being an Ubuntu newbie I would appreciate it if you could provide some web links for documentation / policy information for these.

JM Williams (jmdwilliams) wrote :

I think that whether a feature request is trivial or not is related to the
complexity of the solution rather than that of the problem.

You ask whether usability bugs are trivial. For one thing, don’t worry:
usability is certainly not considered to be trivial! For another, bugs are
never trivial: only feature requests. So if this report is considered to be a
bug rather than a feature request, it will be given a priority of Low, Medium,
High or Critical. Only if it is decided that it is a feature request that is
trivial to implement will it given a priority of Wishlist. So, if it is a
feature request, in fact you want it to be considered trivial, because then
there’s no need for anyone to go and write a spec!

I am new to Launchpad too, by the way (although I have used Debian or Ubuntu
for some time)!

Here are a few links:

    Bug Importance: https://wiki.ubuntu.com/Bugs/Importance
    Launchpad Blueprints: https://blueprints.launchpad.net/
    Ubuntu Brainstorm: http://brainstorm.ubuntu.com/
    Launchpad Answers: https://answers.launchpad.net/
    Ubuntu Forums: http://ubuntuforums.org/

Changed in synaptic:
status: Incomplete → Confirmed

OK, I see what is going on here, however I am left wondering - why are we debating this here? This is essentially a duplicate of bug 31396 which the OP linked to, so I will mark it as so and leave a note on that bug report (I was going to do it the other way around, but...). We can Wishlist the other bug, requesting a right click option or a button for copying.

JM Williams (jmdwilliams) wrote :

I don’t think that this is a duplicate of bug 31396, which is looking for a
GUI method of copying (and for Ctrl+C not to send an interrupt, which should
probably be in a separate report), whereas this report is looking for a
keyboard shortcut, and is probably (my guess!) far easier to implement.

Connor Imes (ckimes) wrote :

I disagree. Both bugs are looking for a, intuitive method to copy from the embedded terminal window.
I don't image using CTRL+C will ever be implemented because that is a standard practice for killing something running in a terminal, which is exactly what is happening and should happen. A specific Wishlist for that would probably be invalidated on the spot.

I don't think a keyboard shortcut is exactly what is needed since the method should be easily recognizable, I think it should be either a button or a mouse function, like right click -> copy.

If you strongly disagree you can unmark the duplicate, otherwise I think we are just creating extra work for developers with different bugs requesting essentially the same thing. Perhaps we should adjust the description of the primary bug to reflect exactly what it is we want done.

JM Williams (jmdwilliams) wrote :

I agree that Ctrl+C is unlikely to be bound to copy, for the reason you gave.
It is a little worrying that someone unfamiliar with Ctrl+C ⇒ SIGINT could
interrupt changes, but then this argument could equally apply to a sudo
command at any terminal. (To head off a possible argument: Synaptic’s
embedded terminal appears only if one twiddles the Details option, but I don’t
think that this is a justification for its being for advanced users only and
therefore acceptably dangerous, because this twiddling is easily
discoverable.)

I agree that there should be an easily recognisable method for copying text (a
button or context menu, as you say), but I don’t think that this precludes a
fairly standard keyboard shortcut from being implemented as well. As I said,
I imagine that a keyboard shortcut would be easier to implement than a GUI
element (there are no usability questions as to where to place a GUI button,
if nothing else), so that could be a justification for its being in a separate
report that could be implemented first.

I’m not sure that having two reports is in this case creating extra work for
developers, since both are fairly simple, well defined bugs or feature
requests that could usefully be attacked sequentially.

I think that the descriptions of the two reports describe the problems quite
well, and it would be hard to put both issues succinctly into one description,
so even if both difficulties are solved by the same Synaptic update, I think
it is worth describing them separately.

They are indeed requesting essentially the same end (easier copying), but by
different means.

While I don’t know that I disagree strongly, I shall unlink the two reports
for now for the reasons I gave above. If you or anyone else does feel
strongly, the reports can be re-linked!

summary: - Cannot copy text in Synaptic’s embedded terminal window with
- Ctrl+Shift+C
+ In embedded terminal Ctrl+Shift+C should copy not send an interrupt
+ signal
Jean-Baptiste Lallement (jibel) wrote :

For consistency with the gnome terminal CTRL+SHIFT+C should copy text and CTRL+C send an interrupt signal. The interrupt signal is currently trapped to ask for confirmation.

tags: added: terminal

Committed to bzr lp:~jibel/synaptic/bug.250359.31396 revno 99
I made the following changes to the shortcuts in the terminal
- CTRL+c : interrupt
- CTRL+SHIFT+c : copy
- CTRL+a : Select all text (maybe useful to copy/paste a full installation output without scrolling the window)
- CTRL+SHIFT+a : Deselect all
I also added a contextual menu with the actions 'copy' and 'select all'

I haven't added CTRL+SHIFT+v because I don't see any useful use case.

Changed in synaptic (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package synaptic - 0.70~pre2ubuntu1

---------------
synaptic (0.70~pre2ubuntu1) natty; urgency=low

  * merged from debian/unstable, remaining changes:
    - ubuntu icons for supported applications
    - launchpad-integration
    - ubuntu changelog download support
    - support section metapackages
    - x-ubuntu-gettext-domain in desktop file

synaptic (0.70~pre2) unstable; urgency=low

  [ Michael Vogt ]
  * po/pt_BR.po:
    - updated, thanks to Sergio Cipolla (closes: #593758)
  * po/id.po:
    - added, thanks to Dirgita
  * po/ru.po:
    - updated, thansk to Yuri Kozlov (closes: #571712)
  * po/de.po:
    - fix fuzzy string, thanks to Alek (closes: #599744)
  * po/et.po:
    - updated, thanks to Guido Tabbernuk
  * po/he.po:
    - updated, thanks to Lior Kaplan and Sergio Cipolla
      (closes: #586940)
  * gtk/rgdebinstallprogress.cc, gtk/rgterminstallprogress.cc:
    - fix FTBFS on latest vte (closes: #597384)
  * common/rpackagecache.{cc,h}, common/rpackage.cc:
    - add cache for PkgFileIterator->pkgIndexFile* to speed up
      RPackage::IsTrusted (LP: #165181)
  * gtk/rgdebinstallprogress.cc:
    - merge fix for error string if those contain a ":"
      (LP: #600658), thanks to Jonathan Thomas and Jean-Baptiste Lallement
  * common/rpackagelister.cc:
    - when sorting by support status use STL stable_parition to speed
      up the list view (thanks to David Purcell)
    - when clicking on the "supported" column, default to showing the
      supported items first, then the unsupported ones
  * gtk/rgmainwindow.cc:
    - show message in quick search label if no apt-xapian-index can
      be found

   [ Jean-Baptiste Lallement ]
   * gtk/rgdebinstallprogress.{cc,h}: Terminal shortcuts fixes
     - fix <CTRL><SHIFT>c behavior (LP: #250359)
     - add shortcuts <CTRL>a and <CTRL><SHIFT>a to select all/none text
       in the terminal
     - add contextual menu to the terminal to select all and copy text
       (LP: #31396)

synaptic (0.70~pre1) unstable; urgency=low

  * New upstream release that merges all changes from
    Debian and Ubuntu into a single tree again. This include libept
    support and lots of fixes.
  * po/sl.po:
    - updated, thanks to Matej Urbančič
  * po/pt_BR.po:
    - updatd, thanks to Sergio Cipolla, closes: #579296
  * gtk/rgmainwindow.cc:
    - fix hang when applying the preferences (LP: #172487)
  * po/th.po:
    - updated, thanks to Theppitak Karoonboonyanan
      (closes: #592696)
  * pre-build.sh:
    - ensure version number gets updated on build

synaptic (0.63.2) unstable; urgency=low

  [ Michael Vogt ]
  * po/uk.po:
    - updated, thanks to Serhij Dubyk
  * po/it.po:
    - updated, thanks to Milo Casagrande (closes: #575685)
  * po/et.po:
    - added, thanks to G. Tabbernuk

  [ Bilal Akhtar ]
  * gtk/rgmainwindow.cc
    - Modify gtk/rgmainwindow.cc to populate package list again after
     'Unmark All' is selected. (LP: #155930)

  [ Jean-Baptiste Lallement ]
  * Fix sorting issues of the package list
    - Fix sort by name and by section (LP: #518509)
    - Improve sort by column performance
  * sort 'installed files' list in alphabetical order (LP: #32550)
  * Set versi...

Read more...

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers