update-manager gives fixed-size window for customised configuration diff

Bug #228928 reported by Ralph Corderoy on 2008-05-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Michael Vogt

Bug Description

Binary package hint: update-manager

Seen when upgrading from 7.10 to 8.04, and before.

When the "Replace the customised configuration file `foo'" window appears containing a unified diff of the customised and intended replacement versions of foo, the window is a fixed size. It can't be resized by the window manager or maximised. Consequently, I'm having to scroll around a diff, horizontally as well as vertically, when over 90% of my screen is available to help out.

In the end, I dug around on a console, found the intended replacement, and diffed them there, but other users may not know how to do that.

I think the diff-display window should be resizable and maximisable.

Related branches

I don't think this is a duplicate of bug #15029. That wants a posher display or an external program. I just want some flags altered so the window manager will let me improve the existing view. This should be a lot quicker and simpler to do.

Changed in update-manager:
importance: Undecided → Wishlist
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in update-manager:
status: New → Confirmed
strank (strank) wrote :

To add another report: This is just happening to me during the upgrade to karmic.
A file-diff presented in a *not-resizable* modal window! It feels like I am using "Windows Installer"...

Please remove this unnecessary restriction from this (and preferably any other) window in update-manager (and preferably any other Ubuntu package).

(My ideal solution would be to remove any option for non-resizable frames from the windowing toolkit itself, since there is never a good reason why anyone but the user should know the best size for a window! Only a minimum size makes sense!)

I'd argue that this is more than a wishlist. Trying to examine a diff of any size or complexity through a small viewport is maddening. It's a bug. Can its importance be reconsidered? I'd have thought it was an ideal candidate for those "papercuts" easy fixes.

Michael Vogt (mvo) on 2009-11-13
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Committed
Michael Vogt (mvo) on 2009-11-13
affects: update-manager (Ubuntu) → synaptic (Ubuntu)
Changed in synaptic (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Wishlist → Low
Nullsub (nullsub) on 2010-12-08
Changed in synaptic (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers