Synaptic insert-cd-upgrade doesn't tell you to expect breakages

Bug #21356 reported by Craig Box on 2005-09-10
6
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Medium
Michael Vogt

Bug Description

Synaptic doesn't give you any indication you shouldn't use your computer while
it's distupgrading.

Firefox gets a bit confused if you're running it during an upgrade - see
screenshot :)

All comes right after reboot. Perhaps the dialogs should notify the user not to
use the PC during the upgrade phase.

http://ellusions.meta.net.nz/~crb/ff-breezy.png: http://ellusions.meta.net.nz/~crb/ff-breezy.png

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I think that really firefox is to blame here. While dist-upgrading is certainly
a pretty big change for a ubuntu system, most applications behave better and do
not crash or act funny. Only the mozilla family seems to be a (big) exception here.

But I agree that it should be better communicated that a dist-upgrade is a _big_
operation that affects basicly the whole system and all installed apps/libs.

The fix will have to wait for breezy+1 because we are in string-freeze already,
sorry.

Cheers,
 Michael

Michael Vogt (mvo) wrote :

The new dist-upgrader in dapper does display a message to expect problems during a dist-upgrade now.

Changed in synaptic:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.