crash after hoary->breezy upgrade

Bug #21225 reported by Michael Vogt on 2005-09-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
High
Michael Vogt

Bug Description

Synaptic crashed after a hoary breezy upgrade:

(synaptic:28097): Gdk-CRITICAL **: gdk_draw_pixbuf: assertion `GDK_IS_DRAWABLE
(drawable)' failed

Gtk-ERROR **: file gtkcontainer.c: line 2447 (gtk_container_propagate_expose):
assertion failed: (child->parent == GTK_WIDGET (container))
aborting...

Program received signal SIGABRT, Aborted.

No usefull backtrace in gdb.

This awfully looks like: http://bugzilla.gnome.org/show_bug.cgi?id=300539
That happend in breezy devel too. I wonder if gtk2.6 (hoary) is affected by this
bug.

Michael Vogt (mvo) wrote :

Created an attachment (id=3648)
the diff that fixes the suspected problem in gtk+

Michael Vogt (mvo) wrote :

Created an attachment (id=3652)
patch ported to gtk2.6

Sebastien Bacher (seb128) wrote :

Upstream has used the same patch for GTK-2-6:
http://cvs.gnome.org/viewcvs/gtk%2B/gtk/gtkicontheme.c?r1=1.39.2.6&r2=1.39.2.7&makepatch=1&diff_format=u

The changes are quite small and work fine, would be nice to have that to
hoary-updates

Michael Vogt (mvo) wrote :

This was libgtk icon theme bug that is fixed now.

Changed in synaptic:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.