Synaptic crashes with bus error (core dumped)

Bug #192567 reported by Boris Hajdukovic on 2008-02-17
4
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: synaptic

First, excuse me for my bad English.

Problem:

I'm not able to start synaptic any more. Synaptic starts and crashes imidietly. If I'm try to start it via terminal, I'm getting:

s7habo@s7habo:~$ sudo synaptic
Bus error (core dumped)

Similar happens if I'm starting apt-get update. Apt-get reads repositories and packages and at the end chrashes with same message:

Bus error (core dumped)

Any idea, what was gone wrong?

I have apport crash file for that problem.

Thanx,

Boris

Boris Hajdukovic (s7habo) wrote :
Iulian Udrea (iulian) wrote :

Thank you for your bug report. Could you please double click on the crash file and let apport do the job for you?

Changed in synaptic:
assignee: nobody → iulian
status: New → Incomplete
Boris Hajdukovic (s7habo) wrote :

Thx for your response Iulian,

I did that but apport crashes too.

Here is crash file from apport

Boris Hajdukovic (s7habo) wrote :

I've just tried to run apport manually wirt the comand line and got:

s7habo@s7habo:~$ sudo apport-cli

*** The program "synaptic" closed unexpectedly on 2008-02-17 at 07:48:34.

If you were not doing anything confidential (entering passwords or other
private information), you can help to improve the application by reporting
the problem.

What would you like to do? Your options are:
  R: Report Problem...
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (R/I/C): r

*** Collecting problem information

The collected information can be send to the developers to improve the
application. This might take a few minutes.
.Bus error (core dumped)
s7habo@s7habo:~$

Boris Hajdukovic (s7habo) wrote :

Very similar issue was described on Ubuntu Forum without solution:

http://ubuntuforums.org/showthread.php?t=635487

Thanks,

Boris

Iulian Udrea (iulian) wrote :

Thank you for the information.

Changed in synaptic:
assignee: iulian → nobody
importance: Undecided → Medium
status: Incomplete → New
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please try to remove /var/cache/apt/*.bin ? And see if that helps?

Changed in synaptic:
status: New → Incomplete
Boris Hajdukovic (s7habo) wrote :

Great! It works!

As Michael suggested, I removed two bin files from /var/cache/apt/ and all seems to work now. Even apport can be used.

Thanks a lot for your help!

Chris Coulson (chrisccoulson) wrote :

This bug report is being closed due to your last comment regarding this being fixed. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in synaptic:
status: Incomplete → Invalid
Mike Rosas (mikerosas) wrote :

Just had this issue on Ubuntu 10.04 LTS... thanks for the tip, it worked for me too = D

Chris Angelico (rosuav-a) wrote :

If anyone's landing here from Google searches, the same thing has been observed on Debian Squeeze. An alternative solution is simply:

$ sudo apt-get update

This fixed it on my system.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers