Only one software management tool is allowed to run at the same time

Bug #165011 reported by David Thornton
6
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Undecided
Andrea Corbellini

Bug Description

Hey,

Sorry i have been having soo much problems with Linux lately (I'm a noob). But back to my problem...anytime when i try to install or uninstall anything it gives me this error message

"Only one software management tool is allowed to run at the same time.
Please close the other application e.g. 'Update manager', 'aptitude' or 'Synaptic' first."

I have tried restarting multiple times! I made sure that nothing else was running. Could you please tell me any programs that may be causing this and how to solve it?

Thanks,
Westin

Revision history for this message
Andrea Corbellini (andrea.corbellini) wrote :

Thanks for taking time reporting this bug.
Unfortunately, this is not a real bug. You should use the "answers" sections to solve your problem.
Feel free to report any other bug you find!

Changed in synaptic:
status: New → Invalid
Revision history for this message
Jen Ockwell (rj-ockwell) wrote :

Have you tried running top in a terminal? It should let you know what programs are running

Revision history for this message
emm (monsler) wrote :

I'm not a n00b. This happened also to me, and while I'm confortable with quite a bit of Linux administration I have used nothing but the Ubuntu happy-wrappers for many months. They typically work great. I'm on 6.06 still.

I strongly suspect there is a real bug underlying this; possibly triggered by e.g. doing multiple "download and install" cycles when prompted, but postponing one of the required reboots.

Regardless, running the synaptic packagage manager rather than just the update manager produced a more helpful error message, that dpkg had struggled and the correct commandline to proceed. To recover, (adding sudo) at the command line I ran:

sudo dpkg --configure -a

entering my password when prompted.

Note that I had killed the update-notifier previously during debugging of the problem. I have no idea if that was related; I doubt it but wanted to give full disclosure.

Revision history for this message
Andrea Corbellini (andrea.corbellini) wrote :

Please, can you tell me which packages has dpkg configured?
Also, did you try to install packages with apt-get?

Changed in synaptic:
status: Invalid → Incomplete
Changed in synaptic:
assignee: nobody → andrea-bs
Revision history for this message
Iulian Udrea (iulian) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem. Please reopen it if you can give us the missing information. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Thank you.

Changed in synaptic:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions