Windows positioning on the screen

Bug #16260 reported by Trouilliez vincent on 2005-04-20
26
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
High
Michael Vogt

Bug Description

When click on the update notifier update, it brings the update-manager main
window. This window is centered on the screen, however, when you click on
"install" to download the pacackages/updates, the little window that pops-up,
always appears at the bottom of the screen, and offset to the right. I keep
dragging it back to the cneter of the screen, to make it more confortable to
look at.
Once everything is downloaded and installed, another pop-up appears, which is
properly centered, hence looks nice/tidy.

So could it be possible to also center the "download"/progress bar pop-up ?

I attached a screenshot to show the offset/strange location of said window.

Created an attachment (id=2154)
untidy location of the "downloading" pop-up

Uphaar Agrawalla (uphaar) wrote :

Yes, I can reproduce this. It should be showing up in the middle, and also
probably remember its position if the user has moved it.

Wayne Davison (wayned) wrote :

Also, if the user makes the update-manager main window bigger (I make it as tall
as possible), the next time it pops up (with the prior height remembered --
thanks!), the bottom of the window is off the screen. It would be better if it
either remembered where the user last put it, or if it calculated the centering
based on the actual window height.

Also, it would be better if the little window that pops-up would allow the user
to make it wider. I like to click on the "show progress of individual files"
option, and the dialog is too narrow to display that data.

Sebastian Heinlein (glatzor) wrote :

The flying dialogs are fixed in the current dapper version.

Regards,

Sebastian

Sebastian Heinlein (glatzor) wrote :

This seems to a bug of metacity, since it doesn't appear using the compiz gnome-window-decorator.

The synaptic dialogs get the window id of the update-manager window. Metacity seems to ignore the transient_for of the synapitc dialogs.

Regards,

Sebastian

that is all

Changed in synaptic:
status: Unconfirmed → In Progress
Michael Vogt (mvo) wrote :

The fix is now in current dapper. I have seen a little mis-alignment to the right, but it's way better than the old version. Please reopen if you still get a bad-looking appearence (and attach a screenshot please).

Thanks,
 Michael

Changed in synaptic:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.