Synaptic has different "main icon" instead of one

Bug #153755 reported by antistress on 2007-10-17
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: human-icon-theme

I really the new Sysnaptic icon that can bee seen here http://img476.imageshack.us/img476/8338/iconsve1.png

However the old icon (3D box with floppy disk and CD) is not dead :
see top left corner of this window http://www.breizh-ardente.fr/dotclear/images/demarrage/maj3.png
and this window http://www.breizh-ardente.fr/dotclear/images/demarrage/maj4.png

i think that the old one should disappear

Related branches

TomasHnyk (sup) wrote :

I can confirm it. A minor nuisance, but it is inconsistent.

Changed in human-icon-theme:
status: New → Confirmed
Changed in human-icon-theme:
importance: Undecided → Low

I'm not really sure where this bug should go...

I believe the "new" synaptic icon which the human theme uses is actually inherited from tangerine, and it does come with a 16x16 "new" synaptic icon. The icon that show in the taskbar and in the corner of the window is the icon which ships with synaptic itself. This probably has to do with synaptic being run as root.

Michael Monreal (mimox) wrote :

Ugh...

The problem here is that the icons should *not* be in the tangerine theme. Putting them there means the right icons will show up (in the menus) for users of a) the tangerine theme and b) the human theme. But all other users (using gnome-icon-theme, tango-icon-theme or any other theme not based on tangerine) will never see the icon.

The solution is to either use icon spec names or let the synaptic package install the icon into hicolor, where every theme can access it. Is there a reason why you don't want to use the "system-software-install" icon provided by the icon spec? There's mo spec name for the update properties icon so that has to be shipped with the update manager's package.

Please, let's fix this bug.

Michael Monreal (mimox) wrote :

Also tangerine is missing 48x48/scalable of both the synaptic and update-properties icons. Hopefully the original author can provide those, too?

Michael Monreal (mimox) wrote :

Re-assigning from human to synaptic, as the original problem is caused by old icons still shipping and used by synaptic and the fact that synaptic should provide these icons, not human or tangerine.

Tomasz Chrzczonowicz (tch) wrote :

The bug is still here in Lucid.

summary: - [Gutsy] Synaptic has different "main icon" instead of one
+ Synaptic has different "main icon" instead of one
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in human-icon-theme (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) wrote :

Set the humanity-icon-theme task to invalid, as that icon comes from synaptic.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in human-icon-theme (Ubuntu):
status: Confirmed → Invalid
Robert Roth (evfool) on 2012-02-17
Changed in synaptic (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Confirmed → In Progress
Robert Roth (evfool) on 2012-07-13
Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
TomasHnyk (sup) wrote :

btw: I cannot reproduce this on quantal, in the dialogs mentioned in the report, there is no icon (so that can count as a fix released, no?)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp1

---------------
synaptic (0.80~exp1) experimental; urgency=low

  [ Robert Roth ]
  * * Disables typeahead in summary dialog, as it doesn't do anything,
    so it's unnecesary (LP: #24319)
  * Move up and Move down buttons in columns preferences changed to
    respect buttons_have_icons preference (LP: #66574)
  * Set the title of the package properties dialog opened for the first
    time (it has not been set before, so it was synaptic the first time
    the dialog has been opened) (LP: #932495)
  * Added a reload button to the repositories changed dialog (LP: #78987)
  * Updated the wording of the expander on the download progress dialog to
    Show individual files" instead of "Show for individual files"
    (LP: #301428)
  * Fixed inconsistencies between column namings in column headers and
    column visibility preferences (LP: #335723)
  * Linkified maintainer label in the package properties dialog
    when running as non-root (LP: #321380)
  * Added package name in the warning scaring you about breaking your
    system (LP: #63974)
  * Added name of the application (Synaptic Package Manager) in the
    titleless dialog shown when starting without administrative
    privilegess (LP: #510261)
  * Improved filter editing checkbox tooltips (LP: #790420)
  * Made all the property values from the package properties dialog
    selectable (LP: #173464)
  * Changed Package Properties accelerator from Ctrl+O to widely used
    (nautilus, eog, evince etc) Alt+Enter (LP: #933554)
  * Use the synaptic icon from the user's icon theme, or fall back to
    the old one if the current theme does not provide a synaptic icon
    (LP: #153755)
  * Focus the Apply button by default. (LP: #488718)
  * Removed log message from automatically installed item click
    (LP: #883984)
  * Fixed delete filter button not working caused by a typo in the
    name of the button when getting it from the GtkBuilder object
    (LP: #779756)
  * Added suggests tasksel as with tasksel installed synaptic
    provides additional functionality (LP: #605186)
  * Fixes incorrect radiobutton handling in the proxy preferences
    (LP: #706262)
  * Fixed incorrect status message when canceling 'Mark all available
    upgrades' feedback dialog (LP: #975578)

  [ Michael Vogt ]
  * ensure external helpers are runs as the user uid
  * build for gtk3 and update build-depends
  * move software-propoerties-gtk into suggests
  * strip strings properly in a markings file, thanks to
    Vassilis Palassopoulos (palasso)
  * show source package name in the details (closes: #692528)
  * merged lp:~fitoschido/synaptic/es-redundancy:
    - Remove empty es_ES .po files. Spanish translations are already
      provided in es files. Thanks to Adolfo Jayme Barrientos (fitoschido)
  * common/rpackagelister.cc:
    - add support for complete removal (purge) in the markings file

 -- Michael Vogt <email address hidden> Thu, 13 Dec 2012 10:08:37 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2012-12-15
no longer affects: human-icon-theme (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers