synaptic/apt-get/Add/Remove errors on Gutsy Beta LiveCD

Bug #150434 reported by Brian Burger on 2007-10-08
6
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
Undecided
Unassigned
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: synaptic

Ubuntu Gutsy Beta LiveCD, checked on first boot with the "Check This CD" ingegrity checker, and passed.

Starts normally, most apps run just fine, but:
* Synaptic will not start at all
* Add/Remove Apps hangs on startup, and has to be killed.
* apt-get or aptitude from the command line complain that something else is already using dpkg:
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

There is nothing running (visible in gnome-system-monitor, anyway) that should be locking apt-get out like that.

And a dpkg lock shouldn't be preventing Synaptic or Add/Remove from starting.

This could well be an error in my livecd, but the ISO checked out w/ md5sum and the 'Check This CD' app reported no errors.

David Portwood (dzportwood) wrote :

All things aside, a dpkg lock should most certainly prevent synaptic, or any package manager from running. The LiveCD uses both internet and the local cd repo, is it possible synaptic was just busy timing out during its operation? or did it hard lock with no errors? Can you try and run synaptic from a terminal to get the output of why it will not start? if it does start and crashes we could use that output also (will be in /var/crash/).
Thanks,
David P.

Changed in gnome-app-install:
status: New → Invalid
Changed in synaptic:
status: New → Incomplete
edu jose (pepinmore) wrote :

I get these same error messages if I try to open Synaptics while Update Manager is running . After it has finished, Synaptics can be used and these error messages disappear. I believe this one is normal.

In my computer Update Manager doesn't show up its icon in the system tray till it's half-done. But can be noticed by the modem activity lights. I haven't tried gnome-system-monitor to look at the process though.

This is in an installed system, in the live CD I have not tried it.

David Portwood (dzportwood) wrote :

Well you need to retitle your bug and leave out the LIVECD part, it is very confusing.
The expected behavior for synaptic is to not run if dpkg has a lock, if for some reason dpkg dies un-expectedly its lockfile will remain, preventing subsequent attempts to use apt, aptitude, dpkg, synaptic, add/remove programs from running. Deleting the lockfile (/var/lib/dpkg/lock) will fix this.

David Portwood (dzportwood) wrote :

Sorry to the bug reporter, I was replying to Eduardo Jose Moreira. Eduardo could you please file a separete bug, or support request, as yours has different circumstances.

Brian Burger (bburger) wrote :

Starting both synaptic & gnome-app-install from terminal show no errors, but they both hang right after starting.

Trying apt-get first gets a complaint about dpgk lock, which is resolved with "sudo rm /var/lib/dpkg/lock" - but running apt-get or aptitude a second time results in either hanging at "Reading package lists... 0%" Ctrl+C doesn't stop them, and kiling gnome-terminal leaves dpgk locked again.

sources.list looks entirely standard:
=========================
deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Beta i386 (20070925.2)]/ gutsy main restricted
deb http://archive.ubuntu.com/ubuntu gutsy main restricted
deb-src http://archive.ubuntu.com/ubuntu gutsy main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://archive.ubuntu.com/ubuntu gutsy universe
# deb-src http://archive.ubuntu.com/ubuntu gutsy universe

deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
=========================

"ps aux | grep synaptic" shows:
ubuntu@ubuntu:~$ ps aux | grep synaptic
ubuntu 14828 0.0 0.4 13440 5028 ? S 02:47 0:00 gksu /usr/sbin/synaptic
root 14829 0.0 1.3 34052 13620 ? Ds 02:47 0:03 /usr/sbin/synaptic
root 15467 0.0 1.2 33944 13372 ? Ds 05:18 0:00 synaptic
ubuntu 15698 0.0 0.0 2972 752 pts/3 R+ 05:36 0:00 grep synaptic

"sudo killall -9 synaptic" gets:
Killed synaptic(14829) with signal 9
Killed synaptic(15467) with signal 9

...but running the px aux command again gets *exactly* the same results. Attempting to run "sudo killall -9 15467" gets:
15467: no process killed

Bad LiveCD, or bug in Gutsy?

David Portwood (dzportwood) wrote :

Typically you want to just use 'sudo kill -9 pid pid pid pid', are you running the command in terminal with the CD in? as your sources.list reflects the CD repository

Brian Burger (bburger) wrote :

This was all in a LiveCD session; evidently the LiveCD uses itself as a source, or at least lists itself.

Using the same CD in the same computer, I've now got Add/Remove & Synaptic working, at least for this session.

This might have been one of those "computers being stupid" things - I'm going to use the same CD tomorrow on a friend's machine, so we'll see what it does then.

Hi guys,
as i just mentioned here (https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/138915/comments/13),
a unionfs bug prevents the use apt and all the frontends such as synaptic,gnome-app-install,etc in the live session.

I think we have to raise the importance of bug 138915 to release-critial!!!
so this is clearly a duplicate of bug 138915.

this is not a bug of synaptic

Changed in synaptic:
status: Incomplete → Invalid
Colin Watson (cjwatson) wrote :

Angelo, bug 138915 is already release-critical (it has the ubuntu-7.10-rc milestone set); we are well aware that it needs to be fixed before release, and indeed a fix is in progress. Please remain in your seat until the aircraft has come to a complete stop, and do not panic. :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers