Text on "Show Details" button should change when clicked

Bug #14548 reported by Peter Whysall on 2005-03-26
8
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Unassigned

Bug Description

When performing actions on packages, the Summary window has a button that allows
the user to show the details of the actions to be performed. When clicked, the
detailed view appears. However, the text on the button still remains "Show
Details". Shouldn't this say "Hide Details" when the detailed view is visible?

Alternatively, isn't the collapsible tree view displaying the same information
as the detailed view? I don't think that the detailed view is really any more
detailed; it's just a non-tree-view of the same information.

Peter Whysall (peter-whysall) wrote :

Created an attachment (id=1861)
Here's the non-detailed view.

Peter Whysall (peter-whysall) wrote :

Created an attachment (id=1862)
Here's the detailed view.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This issues will be fixed after the hoary release. Changing the string at this
stage would mean breaking the translations.

Michael Vogt (mvo) wrote :

I had a look at this issue again and I agree that the interface is not as good
as it could be. The gnome HIG says that toggle buttons like this one shouldn't
be used on it's own but only with other toggle buttons. So this could be changed
to a regular button with "show details" and "hide details". The current UI is
somewhat consistent in the way that the toggle in pressed "in" when the details
are shown and "out" when the details are not shown. Do you think a regular
button would be better and less confusing?

The details view does provide more information that the treeview i.e. it does
display version information.

Thanks,
 Michael

James Bennett (jbennett) wrote :

Since there's already a tree control, with its associated expansion action, is
there a need for this button at all?

Martin Bergner (martin-bergner) wrote :

First of all, I can confirm this bug for dapper.

I think, that the detailed view is ok, since it shows the version which will be installed/removed, you don't get the information (at this stage) by other means.

Changed in synaptic:
status: Needs Info → Confirmed
Michael Vogt (mvo) on 2009-06-09
Changed in synaptic (Ubuntu):
assignee: Michael Vogt (mvo) → nobody
Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.