firefox is already running error

Bug #138454 reported by Vadim Peretokin on 2007-09-09
4
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: synaptic

Hello,

I've came across a problem in Synaptic's 'Report a Problem' feature... it's a bit problematic itself.

I wanted to report a bug, so I clicked on the button. My firefox was already open, but Synaptic, after it gathered the data it needed, gave me a 'firefox is already running' error.

I've closed firefox, tried the button, and it worked fine.

So I suspect there's something wrong in the way it launches firefox - could that be checked please?

Thank you.

ProblemType: Bug
Architecture: i386
Date: Sun Sep 9 13:47:44 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/sbin/synaptic
Package: synaptic 0.57.11.1ubuntu14
PackageArchitecture: i386
ProcCmdline: /usr/sbin/synaptic
ProcCwd: /home/vadi
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
Uname: Linux vadi-laptop 2.6.20-16-generic #2 SMP Fri Aug 31 00:55:27 UTC 2007 i686 GNU/Linux

Vadim Peretokin (vperetokin) wrote :

Confirmed on Ubuntu Feisty.

I don't know if this bug is apport related or synaptic related. When reporting a bug from another program, there's no problem.

Changed in synaptic:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

What prefered browser command is configured? Could you try if that happens with gutsy?

Changed in launchpad-integration:
importance: Undecided → Low
status: Confirmed → Incomplete
Vadim Peretokin (vperetokin) wrote :

I didn't change the command since I got ubuntu, so it should be default. It's "firefox %s" in preferred applications, and the "open link with web browser default" is selected.

I'll only try that in Gutsy after it's officially released, sorry - I only have one laptop, and I need it for work. So someone else who can experiment could try it.

Sebastien Bacher (seb128) wrote :

The feature is known to be working on gutsy or we would have received several bugs about it which is not the case. Do you have any error if you run synaptic from a command line? Do you get the issue with synaptic only or also with other applications?

Vadim Peretokin (vperetokin) wrote :

I tried sudo synaptic from the command line, but received no error in it (still got the firefox already running though).

I tried this feature from gedit, and the calculator - so I think this is just synaptic-specific.

Is there anything else I can provide?

Sebastien Bacher (seb128) wrote :

likely a synaptic bug if that's happening only when using this software

Changed in launchpad-integration:
status: Incomplete → New
Bryan Quigley (bryanquigley) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in synaptic:
status: New → Incomplete

Yes, this still is an issue on 8.04.1.

Just open Firefox, go to synaptic, help, report a problem, let apport
collect data and then you get the error message.

Bryan Quigley (bryanquigley) wrote :

Does it occur when you do help -> Get Help Online?

Vadim Peretokin (vperetokin) wrote :

No, it does not - however for some reason it opens Midori when Firefox is
set as my preferred browser in System - Preferences - Preferred
Applications.

Bryan Quigley (bryanquigley) wrote :

Can you try this with a new user account and see if you still get the error?

Bryan Quigley (bryanquigley) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in synaptic:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers