Synaptic - Translation missing for pkexec dialog

Bug #1260484 reported by M4he on 2013-12-12
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Ubuntu German Translators
synaptic (Ubuntu)
Medium
Unassigned

Bug Description

1. What does happen?
When opening synaptic using the policykit authentication (i.e. via 'synaptic-pkexec'), the policykit authentication dialog says "Authentication is required to run the Synaptic Package Manager" despite the system being set to German language.

2. What should happen?
The dialog should say "Eine Authentifizierung wird benötigt, um die Synaptic Paketverwaltung zu starten.". (I phrased that exactly like gparted-pkexec does)

3. What files/packages are affected?
The policy file is located at "/usr/share/polkit-1/actions/com.ubuntu.pkexec.synaptic.policy" and is part of the package "synaptic"

4. Proposed solution?
To fix this, just put the following line into the above mentioned file:

    <message xml:lang="de">Eine Authentifizierung wird benötigt, um die Synaptic Paketverwaltung zu starten.</message>

Hans Joachim Desserud (hjd) wrote :

The string in question seems to be which has been translated upstream [1] a while back. However, when I look at the synaptic package in Ubuntu [1], it is listed towards the end along in the sections with unused translations. (I looked at Trusty, the current development version) Not sure why the translation is not being used though.

[1] https://translations.launchpad.net/synaptic/main/+pots/synaptic/de/707/+translate
[2] http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/synaptic/trusty/view/head:/po/de.po

M4he (mahe) wrote :

Seems to be the same as with the string "Architecture" which is also commented out and isn't translated on the GUI either.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Klaus Bielke (k-bielke) wrote :

Bug still present in Ubuntu 14.04 LTS (trusty).

Phillip Sz (phillip-sz) on 2014-07-13
Changed in ubuntu-translations:
assignee: nobody → Ubuntu German Translators (ubuntu-l10n-de)
tags: added: trusty
Phillip Sz (phillip-sz) on 2014-07-13
tags: added: utopic
Changed in ubuntu-translations:
status: New → Fix Committed
Tobias Bannert (toba) wrote :

If I open synaptic-pkexec in Linux Mint 17 (Qiana) (Ubuntu 14.04) the authentication text is in german.

Changed in ubuntu-translations:
importance: Undecided → Medium
Changed in synaptic (Ubuntu):
importance: Undecided → Medium
Phillip Sz (phillip-sz) on 2015-04-08
Changed in ubuntu-translations:
status: Fix Committed → Fix Released
Hans Joachim Desserud (hjd) wrote :

Based on the duplicate bug reports this seem to affect all languages.

For reviewers: note that bug 1357728 contains a suggested patch for this issue.

summary: - Synaptic - German - Translation missing for pkexec dialog
+ Synaptic - Translation missing for pkexec dialog
tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers