synaptic crashes when removing residual config or obsolete package

Bug #1176700 reported by Jane Atkinson on 2013-05-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
High
Unassigned

Bug Description

This is happening on saucy testing installs, both with openbox and unity. Both are built up from minimal installs using --no-install-recommends to keep the system lightweight.

When I go to remove a residual config or an obsolete package, synaptic locks up. It's necessary to issue the command

sudo killall synaptic

before I can launch it again.

[Removed unrelated warning that is bug #1135687.]

Other functions in synaptic work normally, as far as I can tell.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: synaptic 0.80~exp2
ProcVersionSignature: Ubuntu 3.9.0-0.4-generic 3.9.0
Uname: Linux 3.9.0-0-generic i686
ApportVersion: 2.10-0ubuntu1
Architecture: i386
Date: Mon May 6 13:26:32 2013
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_NZ:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
UpgradeStatus: No upgrade log present (probably fresh install)

Jane Atkinson (irihapeti) wrote :
Jane Atkinson (irihapeti) wrote :

Note: synaptic was open but apparently running normally when I ran apport-bug.

Daniel Hartwig (wigs) on 2013-05-06
description: updated

What's the stacktrace if you dump it with gcore when it's locked up?

Jane Atkinson (irihapeti) wrote :

Stacktrace attached. The raw file is huge (>100MiB) so I've archived it.

Jane Atkinson (irihapeti) wrote :

The problem is not occurring in the Unity or Xfce systems now.

I did a reinstall of the Openbox system. The lockups are no longer being caused specifically by trying to remove old packages, but seem to be more random.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Changed in synaptic (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in synaptic (Ubuntu):
status: Triaged → In Progress
Paul White (paulw2u) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect <bug #>

and any other logs that are relevant for this particular issue.

Changed in synaptic (Ubuntu):
status: In Progress → Incomplete
Jane Atkinson (irihapeti) wrote :

I've not seen this behaviour in synaptic for a long time now. The bug can be closed.

Changed in synaptic (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers