GtkNotebook 0x114d4a0 is mapped but visible child GtkLabel 0x1450610 is not mapped

Bug #1135687 reported by Susan Cragin on 2013-02-28
232
This bug affects 44 people
Affects Status Importance Assigned to Milestone
synaptic (Debian)
Fix Released
Unknown
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

(synaptic:7712): Gtk-WARNING **: GtkNotebook 0x114d4a0 is mapped but visible child GtkLabel 0x1450610 is not mapped

When invoking synaptic from terminal, this warning pops up several times.
It does not appear to affect the running of synaptic, as far as I can tell.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: synaptic 0.80~exp1
ProcVersionSignature: Ubuntu 3.8.0-8.17-generic 3.8.0
Uname: Linux 3.8.0-8-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Thu Feb 28 07:44:07 2013
InstallationDate: Installed on 2013-01-04 (54 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130102)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
UpgradeStatus: No upgrade log present (probably fresh install)

Susan Cragin (susancragin) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
mr. Ed (mred) wrote :

Faile too in
Uname: 3.8.0-21-generic #32-Ubuntu SMP Tue May 14 22:16:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Teodori Serge (teodori-serge) wrote :

After synaptic upgrade, the problem still persits. Current Version: 0.80~exp2raring1

Mark-pcnetspec (mark-pcnetspec) wrote :

0.80~exp2raring1 didn't fix the random synaptic crashes for me

I've noticed the random crashes don't occur if you start synaptic from the command line with
sudo synaptic
but the DO occur if it's started with
synaptic-pkexec
or
gksudo synaptic
or
gksu synaptic

Monsta (monsta-mint) wrote :

Try turning this setting on:

Settings -> Preferences -> General -> Show package properties in the main window

and see if the warnings persist.

John Winterton (jwinterton) wrote :

That got rid of the repeated warnings. However, a new one showed up (or wasn't noticed before).

john@john-12-10:~$ sudo synaptic
[sudo] password for john:

(synaptic:3221): IBUS-WARNING **: The owner of /home/john/.config/ibus/bus is not root!

Of course I am not running as root. I never (well, hardly ever) run as root. Suicide is not one of my attributes.

Monsta (monsta-mint) wrote :

There's no point in it: sudo is for console apps, gksu is for GUI ones.

Try also this: turn the aforementioned setting on once (or just start synaptic with it turned on), then off, and only then start working with the package list, e.g. browsing, selecting, scrolling with both keys and mouse, etc. See if the warnings appear.

MMlosh (mmlosh) wrote :

There is a point of sudo for GUI apps:
When you are already authenticated for sudo in the console, it's simple to do say "sudo synaptic" and it'll work

John Winterton (jwinterton) wrote :

Well, I just tried it with gksu and got a better result. However, funny error messages are not really that funny. Perhaps whoever is maintaining synaptic should be made aware that there is an outstanding fix to be done.

On 07/28/2013 11:25 AM, Monsta wrote:
> Try turning this setting on:
>
> Settings -> Preferences -> General -> Show package properties in the
> main window
>
> and see if the warnings persist.
>

That resolves here, no more spamming .xsession-errors in 13.04 or
.cache/upstart/gnome-session.log in 13.10
Could be considered to make that option the default.

Here I only open synaptic as currently intended - with pkexec
For those unaware the command is synaptic-pkexec

Monsta (monsta-mint) on 2013-09-29
no longer affects: synaptic
Monsta (monsta-mint) wrote :

Fixed in 0.80.3, but that version didn't make it to Ubuntu 13.10 (yet?).

Changed in synaptic (Debian):
status: Unknown → Fix Released
origoman (origomsn) wrote :

Confumed

Monsta (monsta-mint) wrote :

Should be fixed in Trusty. Can anyone using Trusty confirm this?

Doug McMahon (mc3man) wrote :

No longer an issue in trusty

synaptic (0.80.3) unstable; urgency=low

  * gtk/rgmainwindow.cc, gtk/gtkbuilder/window_main.ui:
    - workaround "Gtk-WARNING **: GtkNotebook 0x998580 is mapped but visible
      child GtkLabel 0x9ac140 is not mapped" by setting "show_tabs=True" in
      the GtkBuilder file and then setting it in buildInterface() again
      (closes: #721539)
    - fix warning" Gtk-CRITICAL **: gtk_tree_row_reference_new_proxy:
      assertion `path->depth > 0' failed" (closes: #721539)
  * gtk/rgpreferenceswindow.{cc,h}:
    - make button colored in the preferencess window again, this broke
      because gtk3 and gtk_widget_override_background() does not work
      (see gtk bug https://bugzilla.gnome.org/show_bug.cgi?id=656461)

 -- Michael Vogt <email address hidden> Tue, 10 Sep 2013 11:24:31 +0200

Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.