Should not pop up error messages when there is no user action

Bug #74712 reported by Trouilliez vincent
4
Affects Status Importance Assigned to Milestone
Sylpheed
Invalid
Undecided
Unassigned
sylpheed (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

I have set Sylpheed to poll the POP server for new mail every 3 minutes.

Problem: because my ISP has become crappy in the recent weeks, sylphed often times out trying to connect to the pop server, and pops up an error window to tell me about it.
This window is very annoying/disturbing, and useless because 1) I can't do anything about the problem anyway 2) in 100% cases, the next attempt to connect will be successfull

What I would expect Sylpheed to do is to only display error pop ups when there is USER action (when the guy manually clicks the "get/all" button on the toolbar), but should stay silent/non-interactive otherwise.

Revision history for this message
Matthew Lloyd (lloyd-matthew) wrote :

Thanks for your report. Your idea might get more attention and have
the possibility of being implemented if you would submit a
specification for this.

You should first check whether it already exists at the Ubuntu specs
page (https://launchpad.net/distros/ubuntu/+specs) in Launchpad. If
that is the case, feel free to contact the drafter of that spec about
your comments/suggestions. Otherwise you can start writing a spec
following the steps described in
        https://wiki.ubuntu.com/FeatureSpecifications.

Changed in sylpheed:
status: Unconfirmed → Rejected
Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

Hello,

I don't really understand why you reject the bug, and also why you make it sound like a feature request (there is nothing to "implement", but just pop ups to disable), and a feature/spec is inadequate, as it only (as I understand it) applies to the development of Ubuntu, not programs from the Universe repository.

Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

Could this bug please be reported upstream (and a "bug watch" added here, for tracking), so it can be fixed eventually ? It still exists in Hardy/Ubuntu 8.04, and is very much annoying...

Changed in sylpheed:
status: Invalid → Confirmed
Revision history for this message
Evgeni Golov (evgeni) wrote :

Well, what is wrong with this:
Configuration -> Common Preferences -> Details -> Other ->
Don't popup error dialog on receive error

Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

Problem solved: was just a matter of setting the right options in the Preferences dialog, he he... :-)

Changed in sylpheed:
status: New → Invalid
Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

the problem was easily solved simply by setting some relevant options in the Preferences dialog... "bug" closed then.

Changed in sylpheed:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers