Remove sword-language-packs(BS) and ichthux-live(B) from Ubuntu

Bug #684510 reported by Dimitri John Ledkov on 2010-12-03
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ichthux-meta (Ubuntu)
Low
Ralph Janke
sword-language-packs (Ubuntu)
Undecided
Colin Watson

Bug Description

== sword-language-packs (S+B) ==

This is a meta-package "generator" which should install sword-text-* packages by language.

1) it's not in Debian
2) It's buggy Bug #635935 Bug #614151
3) Current https://launchpad.net/ubuntu/+source/sword maintainers in Debian/Ubuntu https://launchpad.net/~pkgcrosswire do not see a point of this package, do not want to take up it's maintenance and believe it's obsolete.
4) Current Sword frontends: Xiphos (Gtk) and BibleTime (KDE) support installing sword-text-* from updated Crosswire repositories. Current sword-text-* bibles have well known names and are easily discoverable.

Please remove source package and all binary packages:
sword-language-packs
sword-language-pack-ar: Sword modules for the Arabic language
sword-language-pack-de: Sword modules for the German language
sword-language-pack-el: Sword modules for the Greek language
sword-language-pack-en: Sword modules for the English language
sword-language-pack-es: Sword modules for the Spanish language
sword-language-pack-fr: Sword modules for the French language
sword-language-pack-he: Sword modules for the Hebrew language
sword-language-pack-it: Sword modules for the Italian language
sword-language-pack-nl: Sword modules for the Dutch language
sword-language-pack-ru: Sword modules for the Russian language
sword-language-pack-sw: Sword modules for the Swahili language
sword-language-pack-tl: Sword modules for the Tagalog language
sword-language-pack-vi: Sword modules for the Vietnamese language

== ichthux-live (B-only) ==

Please remove binary package ichthux-live only (source package is ichthux-meta), because it is rdepends of the above packages. This will not affect ichthux, since user installation is used using the ichthux-desktop package.

Ichthux maintainer is not responding.

Micah Gersten (micahg) wrote :

It seems that all the packages that the generated packages depended on were dropped for Lucid. There is one issue and that there's an rdepend left on ichthux-live. I'm subscribing the maintainer for comment and unsubscribing ubuntu-sponsors.

Changed in sword-language-packs (Ubuntu):
status: New → Incomplete

Last update on the itchux derivative page was more than a year a go. [1]

Maybe it needs to be dropped as well?

[1] http://ichthux.com/

Dimitri John Ledkov (xnox) wrote :

see updated description

summary: - Remove sword-language-packs from Ubuntu
+ Remove sword-language-packs(BS) and ichthux-live(B) from Ubuntu
description: updated
Changed in sword-language-packs (Ubuntu):
status: Incomplete → New
Benjamin Drung (bdrung) wrote :

I am against removing this meta-package, because

1) I want to install all bible texts that are available in my language.

2) I prefer the package from the archive over downloading something from the web (especially on computers where I have no Internet access, but access to a local copy of the archive).

Ralph Janke (txwikinger) wrote :

I will remove the packages from the seeding for ichthux.

Changed in ichthux-meta (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Ralph Janke (txwikinger)
Micah Gersten (micahg) wrote :

@Benjamin Drung

If Debian is unwilling to maintain it, someone would have to step forward in Ubuntu to maintain the package. If you'd like to maintain it, please go ahead, otherwise after the rdepends are taken care of I'll approve the removal.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sword-language-packs (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

ichthux-meta was removed some time ago; see bug 1017907 for details.

Changed in ichthux-meta (Ubuntu):
status: In Progress → Fix Released
Colin Watson (cjwatson) wrote :
Download full text (4.6 KiB)

I don't think there's any point waiting more years for people to step up to maintain these packages properly. I have removed them from the saucy archive now.

Removing packages from saucy:
        sword-language-packs 0.3ubuntu1 in saucy
                sword-language-pack-ar 0.3ubuntu1 in saucy amd64
                sword-language-pack-ar 0.3ubuntu1 in saucy arm64
                sword-language-pack-ar 0.3ubuntu1 in saucy armhf
                sword-language-pack-ar 0.3ubuntu1 in saucy i386
                sword-language-pack-ar 0.3ubuntu1 in saucy powerpc
                sword-language-pack-de 0.3ubuntu1 in saucy amd64
                sword-language-pack-de 0.3ubuntu1 in saucy arm64
                sword-language-pack-de 0.3ubuntu1 in saucy armhf
                sword-language-pack-de 0.3ubuntu1 in saucy i386
                sword-language-pack-de 0.3ubuntu1 in saucy powerpc
                sword-language-pack-el 0.3ubuntu1 in saucy amd64
                sword-language-pack-el 0.3ubuntu1 in saucy arm64
                sword-language-pack-el 0.3ubuntu1 in saucy armhf
                sword-language-pack-el 0.3ubuntu1 in saucy i386
                sword-language-pack-el 0.3ubuntu1 in saucy powerpc
                sword-language-pack-en 0.3ubuntu1 in saucy amd64
                sword-language-pack-en 0.3ubuntu1 in saucy arm64
                sword-language-pack-en 0.3ubuntu1 in saucy armhf
                sword-language-pack-en 0.3ubuntu1 in saucy i386
                sword-language-pack-en 0.3ubuntu1 in saucy powerpc
                sword-language-pack-es 0.3ubuntu1 in saucy amd64
                sword-language-pack-es 0.3ubuntu1 in saucy arm64
                sword-language-pack-es 0.3ubuntu1 in saucy armhf
                sword-language-pack-es 0.3ubuntu1 in saucy i386
                sword-language-pack-es 0.3ubuntu1 in saucy powerpc
                sword-language-pack-fr 0.3ubuntu1 in saucy amd64
                sword-language-pack-fr 0.3ubuntu1 in saucy arm64
                sword-language-pack-fr 0.3ubuntu1 in saucy armhf
                sword-language-pack-fr 0.3ubuntu1 in saucy i386
                sword-language-pack-fr 0.3ubuntu1 in saucy powerpc
                sword-language-pack-he 0.3ubuntu1 in saucy amd64
                sword-language-pack-he 0.3ubuntu1 in saucy arm64
                sword-language-pack-he 0.3ubuntu1 in saucy armhf
                sword-language-pack-he 0.3ubuntu1 in saucy i386
                sword-language-pack-he 0.3ubuntu1 in saucy powerpc
                sword-language-pack-it 0.3ubuntu1 in saucy amd64
                sword-language-pack-it 0.3ubuntu1 in saucy arm64
                sword-language-pack-it 0.3ubuntu1 in saucy armhf
                sword-language-pack-it 0.3ubuntu1 in saucy i386
                sword-language-pack-it 0.3ubuntu1 in saucy powerpc
                sword-language-pack-nl 0.3ubuntu1 in saucy amd64
                sword-language-pack-nl 0.3ubuntu1 in saucy arm64
                sword-language-pack-nl 0.3ubuntu1 in saucy armhf
                sword-language-pack-nl 0.3ubuntu1 in saucy i386
                sword-language-pack-nl 0.3ubun...

Read more...

Changed in sword-language-packs (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers