swig 3.0.8 is broken; update to a newer version

Bug #1628974 reported by dimi
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
swig (Ubuntu)
Fix Released
Undecided
Unassigned
Xenial
Confirmed
Undecided
Unassigned
Yakkety
Confirmed
Undecided
Unassigned

Bug Description

There are confirmed errors in swig 3.0.8 that break building python bindings on Ubuntu 16.04.

https://github.com/swig/swig/issues/611

The version 3.0.9 has fixed the problem and should be packaged instead.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in swig (Ubuntu):
status: New → Confirmed
Changed in swig (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Andy Mender (mender27) wrote :

Ubuntu 16.04 LTS and 16.10 still use the buggy swig 3.0.8 version. Could 3.0.10 from Zesty or 3.0.9 be at least moved to xenial-backports and yakkety-backports, respectively? Being stuck on swig 3.0.8 makes this swig version hardly usable.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in swig (Ubuntu Xenial):
status: New → Confirmed
Changed in swig (Ubuntu Yakkety):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers