swauth required for auth in diablo

Bug #893134 reported by Tom Ellis on 2011-11-21
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
swift (Ubuntu)
Undecided
Canonical Server Team

Bug Description

Since swift 1.4, swauth was deprecated from the 'swift' package. However it's mentioned in all swift documentation and is the most complete authentication method at this time.

It's now available as a separate download from: https://github.com/gholt/swauth

Unfortunately, as keystone was not fully part of the Diablo release, we don't have a good authentication method for swift in Oneiric (tempauth is really not production worthy).

Could we get a package for this in oneiric-updates?

There is also many remnants of it in the 'swift' package:
/usr/share/man/man8/swauth-list.8.gz
/usr/share/man/man8/swauth-add-user.8.gz
/usr/share/man/man8/swauth-prep.8.gz
/usr/share/man/man8/swauth-delete-account.8.gz
/usr/share/man/man8/swauth-delete-user.8.gz
/usr/share/man/man8/swauth-add-account.8.gz
/usr/share/man/man8/swauth-set-account-service.8.gz
/usr/share/man/man8/swauth-cleanup-tokens.8.gz

https://answers.launchpad.net/swift/+question/162957
https://answers.launchpad.net/swift/+question/170431

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in swift (Ubuntu):
status: New → Confirmed
Tom Ellis (tellis) wrote :

This change removed swauth and put in the tempauth script:
https://code.launchpad.net/~gholt/swift/deswauth/+merge/62392

I don't expect us to revert that, I just think we need swauth's package in the archive.

Could you please take a look and see if any action is necessary?

Changed in swift (Ubuntu):
assignee: nobody → Canonical Server Team (canonical-server)
assignee: Canonical Server Team (canonical-server) → nobody
assignee: nobody → Canonical Server Team (canonical-server)
Chuck Short (zulcss) wrote :

This has been fixed in precise

Changed in swift (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers