Sync swift-im 2.0+dev6-1 (universe) from Debian unstable (main)

Bug #1250884 reported by Artur Rona on 2013-11-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
swift-im (Ubuntu)
Undecided
Unassigned

Bug Description

Please sync swift-im 2.0+dev6-1 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * No change rebuild for Boost 1.54 transition.
  * Apply a patch from fedora to build against boost filesystems version 3.
  * Use boost::TIME_UTC_.
  * Add missing boost/thread include.
  * Apply a patch from fedora to build against boost filesystems version 3.
  * Use boost::TIME_UTC_.
  * Add missing boost/thread include.

Debian/upstream has merged a part of Ubuntu delta and it builds fine (i386).

Changelog entries since current trusty version 2.0~beta1+dev47-1ubuntu2:

swift-im (2.0+dev6-1) unstable; urgency=low

  * Update from upstream.
  * Don't conflict with libswiften2 overrides. Closes: 726289
  * Don't conflict with swift-im-dbg overrides. Closes: 726290
  * Don't conflict with libswiften-dev overrides. Closes: 726291

 -- Kevin Smith <email address hidden> Mon, 14 Oct 2013 16:42:12 -0000

swift-im (2.0+dev5-1) unstable; urgency=low

  * Update from upstream.
  * Compiles with boost >= 1.50.0; will build on sid again. Closes: #713725
  * Include dependencies for libswiften so that other packages
    can depend on it. Closes: #714902

 -- Kevin Smith <email address hidden> Mon, 12 Aug 2013 16:18:09 -0000

Daniel Holbach (dholbach) wrote :

This bug was fixed in the package swift-im - 2.0+dev6-1
Sponsored for Artur Rona (ari-tczew)

---------------
swift-im (2.0+dev6-1) unstable; urgency=low

  * Update from upstream.
  * Don't conflict with libswiften2 overrides. Closes: 726289
  * Don't conflict with swift-im-dbg overrides. Closes: 726290
  * Don't conflict with libswiften-dev overrides. Closes: 726291

 -- Kevin Smith <email address hidden> Mon, 14 Oct 2013 16:42:12 -0000

swift-im (2.0+dev5-1) unstable; urgency=low

  * Update from upstream.
  * Compiles with boost >= 1.50.0; will build on sid again. Closes: #713725
  * Include dependencies for libswiften so that other packages
    can depend on it. Closes: #714902

 -- Kevin Smith <email address hidden> Mon, 12 Aug 2013 16:18:09 -0000

Changed in swift-im (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers