Ubuntu

CLP missing

Reported by Matevž Jekovec on 2007-01-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
swi-prolog (Ubuntu)
Wishlist
Áron Sisak

Bug Description

Binary package hint: swi-prolog

I'd suggest putting CLP package along (current ubuntu version doesn't bring clpr and clpq libraries and therefore any other clp libraries fail to load).

This is found in "packages/clpqr" directory in swi-prolog mainstream source file. CLP is a library for arithmetic operations. Default prolog ones are really basic and clumsy and not useful for anything more serious (mostly because of one-way instantiation only).

Áron Sisak (asisak) wrote :

Thanks for your bug-report! I think these packages are distributed as separate packages. All these are built from only one source package, though.

What are the (other) CLP libraries that fail to load because of this?

I think, if something distributed in the main binary package (swi-prolog) is unusable because of this, it should be included. Otherwise a new binary package should be created for CLP libraries, e.g., swi-prolog-clp.

Changed in swi-prolog:
assignee: nobody → asisak
status: Unconfirmed → Needs Info
Áron Sisak (asisak) on 2007-02-06
Changed in swi-prolog:
importance: Undecided → Wishlist
William Grant (wgrant) wrote :

I'm closing this due to a lack of response. If you can provide the requested information, please reopen the bug.

Changed in swi-prolog:
status: Incomplete → Invalid
Tim (tim-millerandbowman) wrote :

Hi,

I've just installed SWI prolog on ubuntu 7.10, and I an confirm that the above bug does seem to exist. In response to Aron's questions to the original submitter, it may be that these packages are distributed as separate packages, but the library clp/simplex, which installs as default, cannot be loaded without the clpr library. Furthermore, the documentation for clpq and clpr are both installed, which is inconsistent.

Also, I cannot find the clpq or clpr packages via synaptic. Are they distributed via the ubuntu servers?

Cheers,
Tim

Changed in swi-prolog:
status: Invalid → Incomplete
dozer (matthew-pocock) wrote :

Same thing here in hardy. I have apted swi-prolog but clpr was not installed. I can't see a swi-prolog-clpr package.

Lee Woo-jin (eandre83) wrote :

I confirm the same bug in Ubuntu 10.10 Maverick Meerkat.
CLP (both Q and R) are not available, and there is no swi-prolog-clpqr package available.

Erik Theesen (eth88) wrote :

Confirming the bug in Ubuntu 11.04 Natty Narwhal.
The libraries for clpr,clpq and clpqr are missing when installing swi-prolog from the ubuntu-packages.

But I also managed to acquire the missing files, inserted them in the clp directory and it worked out just fine.
Is there any way for me to add them?

Since some swi-libraries included in the ubuntu package rely on some libraries not included,
the missing libraries should be included in the package
instead of making a different package out of them.

Changed in swi-prolog (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers