problems in install and execute

Bug #941954 reported by Paulo Porto on 2012-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sweethome3d (Ubuntu)
Undecided
Unassigned

Bug Description

aptitude install sweethome3d
New pactages will be installed:
  icedtea-netx{a} icedtea-netx-common{a} janino{a} java3ds-fileloader{a}
  javahelp2{a} junit{a} libfreehep-export-java{a}
  libfreehep-graphics2d-java{a} libfreehep-graphicsio-java{a}
  libfreehep-graphicsio-svg-java{a} libfreehep-graphicsio-tests-java{a}
  libfreehep-io-java{a} libfreehep-swing-java{a} libfreehep-util-java{a}
  libfreehep-xml-java{a} libitext-java{a} libjas-plotter-java{a}
  libjava3d-java{a} libjava3d-jni{a} libnb-org-openide-util-java{a}
  libnb-org-openide-util-lookup-java{a} libsunflow-java{a}
  libtablelayout-java{a} libvecmath-java{a} openjdk-6-jre{a} sweethome3d
...
Process menu ...
in File "/usr/share/menu/wine", in line ended with 1:
[...]YPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
[...] ^
End of line inesperaded.
ignore this file with errors...

root@paulo:/home/paulo# sweethome3d
Java 3D ERROR : Unable to query GLX version
    GLX version 1.3 or higher is required
Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
 at com.eteks.sweethome3d.j3d.Component3DManager.getCanvas3D(Unknown Source)
 at com.eteks.sweethome3d.j3d.Component3DManager.getOnscreenCanvas3D(Unknown Source)
 at com.eteks.sweethome3d.swing.HomeComponent3D.createComponent3D(Unknown Source)
 at com.eteks.sweethome3d.swing.HomeComponent3D.<init>(Unknown Source)
 at com.eteks.sweethome3d.swing.HomeComponent3D.<init>(Unknown Source)
 at com.eteks.sweethome3d.swing.SwingViewFactory.createView3D(Unknown Source)
 at com.eteks.sweethome3d.viewcontroller.HomeController3D.getView(Unknown Source)
 at com.eteks.sweethome3d.swing.HomePane.createActions(Unknown Source)
 at com.eteks.sweethome3d.swing.HomePane.<init>(Unknown Source)
 at com.eteks.sweethome3d.swing.SwingViewFactory.createHomeView(Unknown Source)
 at com.eteks.sweethome3d.viewcontroller.HomeController.getView(Unknown Source)
 at com.eteks.sweethome3d.HomeFramePane.<init>(Unknown Source)
 at com.eteks.sweethome3d.HomeFrameController.getView(Unknown Source)
 at com.eteks.sweethome3d.HomeFrameController.displayView(Unknown Source)
 at com.eteks.sweethome3d.SweetHome3D$2.collectionChanged(Unknown Source)
 at com.eteks.sweethome3d.model.CollectionChangeSupport.fireCollectionChanged(Unknown Source)
 at com.eteks.sweethome3d.model.HomeApplication.addHome(Unknown Source)
 at com.eteks.sweethome3d.SweetHome3D.run(Unknown Source)
 at com.eteks.sweethome3d.SweetHome3D$3.run(Unknown Source)
 at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
 at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
 at java.awt.EventQueue.access$000(EventQueue.java:96)
 at java.awt.EventQueue$1.run(EventQueue.java:608)
 at java.awt.EventQueue$1.run(EventQueue.java:606)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
 at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.93-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,imgjpeg,cube,rotate]
CompositorRunning: None
Date: Mon Feb 27 11:36:20 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 fglrx-updates, 8.911, 3.2.0-17-generic-pae, i686: installed
 virtualbox, 4.1.8, 3.2.0-17-generic-pae, i686: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Sony Corporation Device [104d:9084]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120118)
MachineType: Sony Corporation VPCZ215GB
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic-pae root=UUID=721a94a3-e7b4-479f-94c3-3a5f2e82865c ro quiet splash vt.handoff=7
SourcePackage: xorg
UnitySupportTest:
 Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code 1: X Error of failed request: BadRequest (invalid request code or no such operation)
   Major opcode of failed request: 136 (GLX)
   Minor opcode of failed request: 19 (X_GLXQueryServerString)
   Serial number of failed request: 22
   Current serial number in output stream: 22
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/16/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: R0170H5
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnINSYDE:bvrR0170H5:bd06/16/2011:svnSonyCorporation:pnVPCZ215GB:pvrJ004JQGY:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCZ215GB
dmi.product.version: J004JQGY
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Paulo Porto (psporto) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers