sweethome3d does not start in ubuntu 18.10 cosmic

Bug #1797920 reported by corrado venturini on 2018-10-15
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
sweethome3d (Ubuntu)
Undecided
Unassigned

Bug Description

sweethome3d does not start in ubuntu 18.10 cosmic
same problem with sweethome3d 5.7 and 6.0

corrado@corrado-HP-p5-cc-0927:~$ sweethome3d
Inconsistency detected by ld.so: dl-lookup.c: 112: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!
corrado@corrado-HP-p5-cc-0927:~$ apt policy sweethome3d
sweethome3d:
  Installed: 6.0+dfsg-1
  Candidate: 6.0+dfsg-1
  Version table:
 *** 6.0+dfsg-1 500
        500 http://archive.ubuntu.com/ubuntu cosmic/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu cosmic/universe i386 Packages
        100 /var/lib/dpkg/status
corrado@corrado-HP-p5-cc-0927:~$ uname -a
Linux corrado-HP-p5-cc-0927 4.18.0-10-generic #11-Ubuntu SMP Thu Oct 11 15:13:55 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
corrado@corrado-HP-p5-cc-0927:~$

Problem seems due to some recent update. as you can see from the attached terminal output sweethome start ok before updates, then i run apt update+upgrade and after upgrades sweethome does not start.

Doug McMahon (mc3man) on 2018-10-20
Changed in sweethome3d (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Caused by recent upgrade of the openjdk-lts source. Numerous (100+) undefined symbol errors

Prasad Murthy (murthy) wrote :

Specs:

OS:
Kubuntu 18.10

Java:
openjdk 11 2018-09-25
OpenJDK Runtime Environment (build 11+28-Ubuntu-3ubuntu2)
OpenJDK 64-Bit Server VM (build 11+28-Ubuntu-3ubuntu2, mixed mode, sharing)

APP:
sweethome3d package version 6.0+dfsg-1

Error Message: Inconsistency detected by ld.so: dl-lookup.c: 112: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

Sweethome3d crashes with the above message, therefore I confirm this bug.

Stefan Wagner (zordid86) wrote :

After installing the newest snap, sweethome3d runs again.
Used sudo snap install sweethome3d-homedesign to install it.

Gerry (gsker) wrote :

The sweethome3e you get from the snap is version 5.7.

To use the 6.0 version use:

snap refresh --channel edge sweethome3d-homedesign

The reason it works is probably because it includes the Oracle Java JRE.

Martin Měřinský (mermar) wrote :

Cannot run the app:

sudo apt install sweethome3d sweethome3d-furniture sweethome3d-furniture-editor sweethome3d-textures-editor

sweethome3d
Inconsistency detected by ld.so: dl-lookup.c: 112: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments