Sweethome 3D crashes at startup

Bug #1576076 reported by mathojojo on 2016-04-28
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
sweethome3d (Ubuntu)
Undecided
Unassigned

Bug Description

Everytime I try to start Sweethome 3D, the interface appear and then directly crashes !

When I launch it in Terminal, I get this :

Java 3D: implicit antialiasing enabled
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f70066de823, pid=1667, tid=140119133419264
#
# JRE version: OpenJDK Runtime Environment (8.0_03-b03) (build 1.8.0_03-Ubuntu-8u77-b03-3ubuntu3-b03)
# Java VM: OpenJDK 64-Bit Server VM (25.03-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [radeonsi_dri.so+0x256823]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid1667.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)

Not sure if Sweethome3D is the culprit, maybe it's Java, or even Radeonsi drivers...

Tried with Sweethome3D from Ubuntu Repository and a newer version.... but same result !

my system : kubuntu 16.04 64bit / AMD Phenom(tm) II X6 1090T Processor / 8Go RAM / RADEON HD 7750 (no propretary drivers installed, as they are not available anymore in 16.04)

mathojojo (mathojojo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sweethome3d (Ubuntu):
status: New → Confirmed
Claus Koch (clauskoch) wrote :

Same here with OpenJDK

Elendil (cuesdepances) wrote :

I get the same kind of error with the following message in the console:

Java 3D: implicit antialiasing enabled
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f103e9f8823, pid=22735, tid=139707759335168
#
# JRE version: OpenJDK Runtime Environment (8.0_91-b14) (build 1.8.0_91-8u91-b14-0ubuntu4~16.04.1-b14)
# Java VM: OpenJDK 64-Bit Server VM (25.91-b14 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [radeonsi_dri.so+0x256823]
#
# Core dump written. Default location: /usr/share/sweethome3d/core or core.22735
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid22735.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Abandon (core dumped)

Oskar (oskarse) wrote :

Same thing for me when I launch it from terminal on Linux 4.4.0-28-generic #47-Ubuntu SMP Fri Jun 24 10:09:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux:

 sweethome3d
Java 3D: implicit antialiasing enabled
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f74b91df823, pid=3312, tid=140139311171328
#
# JRE version: OpenJDK Runtime Environment (8.0_91-b14) (build 1.8.0_91-8u91-b14-0ubuntu4~16.04.1-b14)
# Java VM: OpenJDK 64-Bit Server VM (25.91-b14 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [nouveau_dri.so+0x256823]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid3312.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)

Graphics are Gallium 0.4 on NVA8.
Java is openjdk version "1.8.0_91"
OpenJDK Runtime Environment (build 1.8.0_91-8u91-b14-0ubuntu4~16.04.1-b14)
OpenJDK 64-Bit Server VM (build 25.91-b14, mixed mode)

Video card is GeForce 8400 GS Rev. 3

madbiologist (me-again) on 2018-09-24
tags: added: xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers