Popup menu flickers on Firefox and Sway combo

Bug #1924800 reported by Huseyin Fahri Uzun
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
sway (Ubuntu)
Low
Unassigned

Bug Description

https://bugzilla.mozilla.org/show_bug.cgi?id=1696662
https://github.com/swaywm/sway/pull/6046

Drop down and context menus flickers on Firefox with WAYLAND enabled on Sway. It fixed on latest Sway version above PR, which is missing on 20.04

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sway (Ubuntu):
status: New → Confirmed
Revision history for this message
Wouter Horré (wouterh) wrote :

There's a backport of the fix to sway 1.5 here:
https://github.com/swaywm/sway/pull/6283

I'll look into publishing a patched packaged to my PPA later this week. It's been a while since I did any ubuntu packaging, so it might take a while to get it right.

Revision history for this message
Wouter Horré (wouterh) wrote :

This is a debdiff that adds the backported fix for this bug available here:

https://github.com/swaywm/sway/pull/6283

This builds successfully in pbuilder. I have installed the updated package and I can confirm the flickering of firefox's popups is gone.

Revision history for this message
Wouter Horré (wouterh) wrote :

I have pushed a package with the fix to a PPA:
https://launchpad.net/~wouterh/+archive/ubuntu/sway

Builds are still running, but updated packages should be available there soon.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "1-1.5.1-2ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Mathew Hodson (mhodson)
Changed in sway (Ubuntu):
importance: Undecided → Low
Revision history for this message
Brian Murray (brian-murray) wrote :

I've gone ahead and uploaded this as an SRU for Impish (21.10) but this bug could use an SRU template. Could you please add one following the guidance at https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template? Thanks in advance.

 $ dput sway_1.5.1-2ubuntu1_source.changes
Trying to upload package to ubuntu
Checking signature on .changes
gpg: /tmp/pkgs/impish/sway_1.5.1-2ubuntu1_source.changes: Valid signature from 1E918B66765B3E31
Checking signature on .dsc
gpg: /tmp/pkgs/impish/sway_1.5.1-2ubuntu1.dsc: Valid signature from 1E918B66765B3E31
Uploading to ubuntu (via ftp to upload.ubuntu.com):
  Uploading sway_1.5.1-2ubuntu1.dsc: done.
  Uploading sway_1.5.1-2ubuntu1.debian.tar.xz: done.
  Uploading sway_1.5.1-2ubuntu1_source.buildinfo: done.
  Uploading sway_1.5.1-2ubuntu1_source.changes: done.
Successfully uploaded packages.

Revision history for this message
Steve Langasek (vorlon) wrote :

This package was incorrectly auto-accepted into impish-proposed by a script. I have subsequently removed it from impish-proposed; since the package has now been accepted and then removed, in order for this SRU process to progress, an SRU template will need to be provided and then someone will need to ping a member of the ~ubuntu-sru team to recover the package from deletion.

Revision history for this message
Steve Langasek (vorlon) wrote : Proposed package upload rejected

An upload of sway to impish-proposed has been rejected from the upload queue for the following reason: "new upstream version, not for SRU".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers