does not work with subversion 1.8

Bug #1322533 reported by Julian Taylor on 2014-05-23
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
eclipse-subclipse (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
svnclientadapter (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]
loading the svnclientadapter e.g. via eclipse subclipse plugin raises an error:
Incompatible JavaHL library loaded. Subversion 1.7.x required.

The version in trusty does not support 1.8, version 1.10.3 available in utopic does support it
As trustys version does not work at all the utopic version should be backported via SRU to trusty.

[TESTCASE]
install eclipse and eclipse-subclipse
try to start the use a svn repository
with current trusty version you get following error message:
Incompatible JavaHL library loaded. Subversion 1.7.x required.

[Regression Potential]
none, the library refuses to setup with subversion 1.8, so an update can't make things worse

Julian Taylor (jtaylor) on 2014-05-23
Changed in svnclientadapter (Ubuntu):
status: New → Fix Released
Changed in svnclientadapter (Ubuntu Trusty):
status: New → Confirmed

Workaround (from duplicate bug 1355097, for those who find this bug report first):

Don't install subversion by Ubuntu package, instead use Eclipse's native plugin installer.
http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA
http://subclipse.tigris.org/update_1.10.x

Hans Joachim Desserud (hjd) wrote :

Thanks for your comment on bug 1355097, Csipak. It very much looks like this is the underlying issue, so I'm rather tempted to mark that as a duplicate of this one. Though in that case I guess the eclipse-subclipse package should be marked as also affecteted by this issue. It's not clear to me from the description, but I assume eclipse-subclipse will need to be SRUed too when svnclientadapter is upgraded in order for the former to work(?)

Thomas Uhle (uhle) wrote :

Both packages eclipse-subclipse and libsvnclientadapter-java have to be updated to version 1.10.3 as pointed out in https://bugs.launchpad.net/ubuntu/+source/eclipse-subclipse/+bug/1355097/comments/1 .

Derek (bugs-m8y) wrote :

So... I'm a bit confused by that last comment.
http://packages.ubuntu.com/trusty/devel/eclipse-subclipse appears to still be 1.8, not 1.10?
Can't seem to find this fixed version for my machine even with backports enabled. Is LTS still broken?

Derek (bugs-m8y) wrote :

FWIW, that seems indeed to be the case. I switched over to Vivd, downloaded eclipse-subclipse and libsvnclientadapter-java, installed them, and after blowing away my local ~/.eclipse that seemed to be a bit confused, possibly from prior errors, everything was fine and svn seems to be working great.

Derek (bugs-m8y) wrote :

... er. to be clear, I switched over to vivid on the packages.ubuntu.com website. The vivid packages seem to work just fine in 14.04 LTS Trusty

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse-subclipse (Ubuntu Trusty):
status: New → Confirmed
Changed in eclipse-subclipse (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers