2.2.1 needs Time::Progress

Bug #317487 reported by Swen Thümmler
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
svk (Ubuntu)
Undecided
MOTU

Bug Description

Binary package hint: svk

the new version 2.2.1 (thanks for the fast packaging) needs the perl module Time::Progress for mirroring, which is not yet available as an ubuntu package. Solution: either remove the progress parts from Mirror.pm and Mirror/Backend/SVNRa.pm or provide libtime-progress-perl.

Revision history for this message
Allisson Azevedo (allisson) wrote :

I'll try to provide libtime-progress-perl

Changed in svk:
assignee: nobody → allisson
status: New → Confirmed
Revision history for this message
Ilja Pavkovic (ipavkovic) wrote :

it is enough to change the function progress in Notify.pm, something like

--- Notify.pm~ 2008-08-05 05:39:23.000000000 +0200
+++ Notify.pm 2009-03-06 12:00:46.681242453 +0100
@@ -211,6 +211,7 @@

 sub progress {
     my $self = shift;
+ return;
     require Time::Progress;
     return if $self->{quiet};
     my $progress = Time::Progress->new();

you will lose some messages but on the other hand svk is still working

Revision history for this message
Ted Gould (ted) wrote :

As a work around it seems if you add:

use_progress=0

To the top of ~/.svk/config it goes away. Another error comes up, but seems to atleast stop the progress error. I'm not sure where the setting goes though, it seems to disappear.

Revision history for this message
VinceLe (legoll) wrote :

Another way to fix it is to run:

sudo cpan Time::Progress

Revision history for this message
LimCore (limcore) wrote :

Good job making SVK useless after upgrade to 9.04, thanks Ubuntu.

At least there is this work around.

So what are we waiting for, lets put it to repos?

Artur Rona (ari-tczew)
tags: added: upgrade
Revision history for this message
Allisson Azevedo (allisson) wrote :

libtime-progress-perl is available in debian unstable:

http://packages.debian.org/sid/libtime-progress-perl

Changed in svk (Ubuntu):
assignee: Allisson Azevedo (allisson) → MOTU (motu)
Revision history for this message
Piotr Czachur (zimnyx) wrote :

WARNING:
Don't add "use_progress=0" like Tedd suggested, because after running some svk command you will *loose* your svk config - svk will overwrite it with a few new lines brand-new config, and become unusable!!! (Can't call method "find" on unblessed reference at /usr/share/perl5/SVK/XD.pm line 361.)
That's what happened to me, and I can reproduce it.

Revision history for this message
astrotom (t-rauscher) wrote :

Is there a fix yet? Would need it urgently as I am heavily using SVK. Thanks a lot Ubuntu for breaking this!

Revision history for this message
LimCore (limcore) wrote :

Does this cause heavy data loss (like, actuall SVK repository) - or "just" the configuration file? Any work aroiund?

Revision history for this message
Allisson Azevedo (allisson) wrote :
Changed in svk (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
scoder (scoder) wrote :

Lucid package works perfectly for me in karmic.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers