package supervisor 3.0a8-1 failed to install

Bug #777862 reported by Billie Thompson on 2011-05-05
184
This bug affects 29 people
Affects Status Importance Assigned to Milestone
supervisor (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: supervisor

$ sudo apt-get install supervisor
Reading package lists... Done
Building dependency tree
Reading state information... Done
supervisor is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up supervisor (3.0a8-1) ...
Starting supervisor: Unlinking stale socket /var/run/supervisor.sock
Traceback (most recent call last):
  File "/usr/bin/supervisord", line 9, in <module>
    load_entry_point('supervisor==3.0a8', 'console_scripts', 'supervisord')()
  File "/usr/lib/pymodules/python2.7/supervisor/supervisord.py", line 371, in main
    go(options)
  File "/usr/lib/pymodules/python2.7/supervisor/supervisord.py", line 381, in go
    d.main()
  File "/usr/lib/pymodules/python2.7/supervisor/supervisord.py", line 94, in main
    self.run()
  File "/usr/lib/pymodules/python2.7/supervisor/supervisord.py", line 104, in run
    self.options.openhttpservers(self)
  File "/usr/lib/pymodules/python2.7/supervisor/options.py", line 1039, in openhttpservers
    self.httpservers = self.make_http_servers(supervisord)
  File "/usr/lib/pymodules/python2.7/supervisor/options.py", line 1242, in make_http_servers
    return make_http_servers(self, supervisord)
  File "/usr/lib/pymodules/python2.7/supervisor/http.py", line 799, in make_http_servers
    from web import supervisor_ui_handler
  File "/usr/lib/pymodules/python2.7/supervisor/web.py", line 29, in <module>
    import meld3
  File "/usr/lib/pymodules/python2.7/meld3/__init__.py", line 2, in <module>
    from meld3 import parse_xml
  File "/usr/lib/pymodules/python2.7/meld3/meld3.py", line 27, in <module>
    from xml.etree.ElementTree import fixtag
ImportError: cannot import name fixtag
invoke-rc.d: initscript supervisor, action "start" failed.
dpkg: error processing supervisor (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for python-support ...
Errors were encountered while processing:
 supervisor
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: supervisor 3.0a8-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu May 5 15:01:34 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
PackageArchitecture: all
SourcePackage: supervisor
Title: package supervisor 3.0a8-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to natty on 2011-04-15 (20 days ago)

Billie Thompson (billiecodes) wrote :

There should exist a fix to the meld3 which causes the problem with the line:
"from xml.etree.ElementTree import fixtag"

I havent found the fix, but used the following workaround (in a terminal) :

sudo apt-get install python-setuptools
sudo apt-get install python-setuptools
sudo easy_install elementtree

intel352 (intel352) wrote :

Jorgen's workaround fixed this issue for myself as well. Installing supervisor under Natty

I can confirm that Jørgen's solution worked for me too, maybe the dependencies just needs to be updated?

summary: - package supervisor 3.0a8-1 failed to install
+ package supervisor 3.0a8-1 failed to install, not python2.7 compatible
summary: - package supervisor 3.0a8-1 failed to install, not python2.7 compatible
+ package supervisor 3.0a8-1 failed to install
nanaya (nanaya) wrote :

It is also reported here: https://bugzilla.redhat.com/show_bug.cgi?id=652890

The proper fix is to update python-meld3 to 0.6.7.

alien8 (fb-alien8) wrote :
Jochem Oosterveen (jocmeh) wrote :

You could also go for:

# apt-get install pip
# pip install meld3
# apt-get install supervisor

This will give you meld3 0.6.7 in /usr/local/lib/python2.7/dist-packages/meld3/, which sits in sys.path before /usr/lib/pymodules/python2.7/meld3/ (and that symlinks to /usr/share/pyshared/meld3/).

Jochem Oosterveen (jocmeh) wrote :

s/pip$/python-pip/ # ugh :)

Changed in supervisor (Ubuntu):
status: New → Confirmed
Raúl Santos (borfast) wrote :

It's been a few months since this was reported but I just stumbled upon the same problem on Ubuntu 11.04. Won't this be fixed?

Gediminas Paulauskas (menesis) wrote :

This crash was fixed by uploading a patched python-meld3, available in Ubuntu 12.04 or later

python-meld3 (0.6.5-3.1) unstable; urgency=low

  * Non-maintainer upload.
  * Apply Ubuntu patch to make the package compatible with Python
    2.7. Thanks to Jessica McKellar. Closes: #644246.
    + Switch to 3.0 (quilt) source format to apply patch cleanly.

 -- Arnaud Fontaine <email address hidden> Mon, 31 Oct 2011 10:48:32 +0900

Changed in supervisor (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.