echo_supervisord_conf fails with IOError

Bug #677011 reported by Piotr Kęplicz on 2010-11-18
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
supervisor (Debian)
Fix Released
Unknown
supervisor (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: supervisor

Ubuntu releases: 10.04, 10.10
Package version: 3.08a-1

echo_supervisord_conf, a command that displays a sample configuration file, fails with the following message:

Traceback (most recent call last):
  File "/usr/bin/echo_supervisord_conf", line 9, in <module>
    load_entry_point('supervisor==3.0a8', 'console_scripts', 'echo_supervisord_conf')()
  File "/usr/lib/pymodules/python2.6/supervisor/confecho.py", line 19, in main
    config = pkg_resources.resource_string(__name__, 'skel/sample.conf')
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 881, in resource_string
    self, resource_name
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1154, in get_resource_string
    return self._get(self._fn(self.module_path, resource_name))
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1281, in _get
    stream = open(path, 'rb')
IOError: [Errno 2] No such file or directory: '/usr/lib/pymodules/python2.6/supervisor/skel/sample.conf'

Indeed, there's no /usr/lib/pymodules/python2.6/supervisor/skel/sample.conf available, it seems to be located at /usr/share/doc/supervisor/examples/sample.conf.gz.

Piotr Kęplicz (keplicz) on 2010-11-18
tags: added: packaging
description: updated
Angel Abad (angelabad) on 2011-06-12
Changed in supervisor (Ubuntu):
status: New → Confirmed
Changed in supervisor (Debian):
status: Unknown → New
nh2 (nh2) wrote :

Present in 12.04 :(

fqj1994 (fqj1994) wrote :

minimal attachment below
please do SRU
Thanks

Changed in supervisor (Debian):
status: New → Fix Released
Daniel Holbach (dholbach) wrote :

Should be fixed with the sync of bug 1206474.

Changed in supervisor (Ubuntu):
status: Confirmed → Fix Released
Bruno Bigras (brunoqc) wrote :

I have this problem on precise. I guess because I still have the old 3.0a8-1.1 version.

Any plan for a SRU?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.