Supertuxkart give me a lot of problems with music using jaunty

Bug #366716 reported by Fabio Colombo on 2009-04-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
supertuxkart (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: supertuxkart

This is what I get from terminal:

blackdiamond@blackdiamond-desktop:~$ supertuxkart
Data files will be fetched from: '/usr/share/games/supertuxkart/'
Highscores will be saved in '/home/blackdiamond/.supertuxkart/highscore.data'.
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
WARNING: Music not playing when it should be. Source state: 4116
blackdiamond@blackdiamond-desktop:~$

It continues to say "WARNING: Music not playing when it should be. Source state: 4116" until I kill the program..
What I can ear is only a terrible noise..

Bye and thanks, hope to be useful.

Fabio

MarkZ (mzmail) wrote :

The same on my machine with jaunty. Before I could use a manually downloaded supertuxkart 0.6.1a version without any problems on my ubuntu 8.10.
Other games (e.g. pingus) sound runs without any problems.

Gergely Máté (sportember) wrote :

Here also, after upgrade to jaunty and STK 0.5 -> 0.6.1a, the audio output is like to be out of sync.
Maybe an OpenAl related problem?

The problem sometimes occurs and sometimes not. Quitting and starting it again may result in working audio (and vice versa).

Hi all!

 Seems I can't reproduce the bad noise here on Debian where I
should have an virtually identical package. The output on the console
however is here visible, too, so I'll investigate in that part
upstream.

--
/"\ ASCII Ribbon : GPG-Key ID: 0x0372275D
\ / Campaign :
 X against HTML : Debian NM
/ \ in eMails : http://www.debian.org/

http://www.christoph-egger.org/

On some hardware configurations, openal-soft doesn't work with the default alsa backend and pulseaudio.
A workaround is to switch the backend to oss. To do that, create a file named ".alsoftrc" in your home directory and put "drivers = oss" in it.

Can you try to set the openal backend to oss in ~/.alsoftrc ? Does that make the problem go away?

I've done this workaround but it doesn't work. Doing that I can't ear any kind of sounds during games (all games and not only supertuxkart).
Deleting the file it make the sound works again, but with the same problem.

Fabio

OSS often does not support a mixer. So you won't have any sound if your
sound output is looked for any other application. So it's pretty normal
to have no sound output in OSS when other applications are running (and
e.g. Instant Messengers and Browsers often already are sound users blocking
any other OSS using application)

--
/"\ ASCII Ribbon : GPG-Key ID: 0x0372275D
\ / Campaign :
 X against HTML : Debian NM
/ \ in eMails : http://www.debian.org/

http://www.christoph-egger.org/

I had the same problem with STK. I'm using jaunty and I have openal as I didn't want to compile openal-soft and so on.
Try setting "drivers = oss" in /etc/openal/alsoft.conf
In my case that solved the problem

MarkZ (mzmail) wrote :

Ok, works great for me. Thank you in the name of my kids!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers