Sync supertuxkart 1.2+ds-1 (universe) from Debian sid (main)

Bug #1893994 reported by Oibaf on 2020-09-02

This bug report will be marked for expiration in 34 days if no further activity occurs. (find out why)

12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
supertuxkart (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync supertuxkart 1.2+ds-1 (universe) from Debian sid (main)

Tested on my PPA at:
https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers/+packages?field.name_filter=supertuxkart&field.status_filter=published&field.series_filter=groovy

Changelog entries since current groovy version 1.1+ds-1build2:

supertuxkart (1.2+ds-1) unstable; urgency=medium

  * Team upload.

  [ QwertyChouskie ]
  * New upstream release:
    - Drop remove_irrlicht_embedded_libs.patch
    - Remove remove_irrlicht_embedded_libs.patch from series
  * Add libsdl2-dev to build-deps. STK 1.2 ported its window creation and
    gamepad handling to SDL2.
  * Update supertuxkart.manpages with correct filename for 1.2.

  [ Reiner Herrmann ]
  * Refresh patches and drop fix-hurd-ftbfs.diff (no longer applicable).
  * Remove paths no longer available upstream from d/rules and d/copyright.
  * Update debhelper compat level to 13:
    - Mark wiiuse.h and libwiiuse.a as not-installed
  * Bump Standards-Version to 4.5.0.
  * Depend on newly used fonts and symlink to them.
  * d/copyright:
    - Document copyright of newly embedded library sheenbidi and new fonts
    - Drop android directory from source tarball via Files-Excluded
    - Update copyrights
  * Point d/watch to Github.
  * Drop unneeded build-dependencies: libbz2-dev, libfribidi-dev, libraqm-dev.
  * Drop from build-dependencies: libwayland-dev, libxkbcommon-dev,
    libegl1-mesa-dev, because window handling is now performed with SDL2.

 -- Reiner Herrmann <email address hidden> Fri, 28 Aug 2020 18:52:58 +0200

Oibaf (oibaf) on 2020-09-02
description: updated
Steve Langasek (vorlon) wrote :

It appears the release team has been subscribed to this bug on the basis that it's requesting an excepton to the feature freeze. What is the rationale for an exception?

Changed in supertuxkart (Ubuntu):
status: New → Incomplete
Oibaf (oibaf) wrote :

Main reason is that Ubuntu players can play online with other users that have the latest version.

There are also some minor new features and improvements/fixes, such as:
- better gamepad support
- IPv6 support on LAN servers
- improved karts

Full release notes here:
https://blog.supertuxkart.net/2020/08/supertuxkart-12-release.html

Changed in supertuxkart (Ubuntu):
status: Incomplete → New
Steve Langasek (vorlon) wrote :

> Main reason is that Ubuntu players can play online
> with other users that have the latest version.

How's this? The release announcement you linked to states that older and newer versions are compatible:

> The SuperTuxKart team is happy to announce the release of version 1.2.
> Online play is still compatible with previous 1.x versions.

So it doesn't look to me like there is a strong justification here for an FFe for groovy.

Changed in supertuxkart (Ubuntu):
status: New → Incomplete
Oibaf (oibaf) wrote :

You are right, sorry, I missed it and for some reason I thought it would be incompatible.

Mathew Hodson (mhodson) on 2020-09-25
Changed in supertuxkart (Ubuntu):
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers